dev-python/fuo-kuwo: update SRC_URI
[gentoo-zh.git] / app-i18n / libime / libime-1.0.17.ebuild
blob5f19a03cab958d88d381bb99fc866dce0b4679cd
1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit cmake xdg-utils flag-o-matic toolchain-funcs
8 if [[ "${PV}" == 9999* ]]; then
9 inherit git-r3
10 EGIT_REPO_URI="https://github.com/fcitx/libime.git"
11 EGIT_SUBMODULES=(src/libime/core/kenlm)
12 else
13 KEYWORDS="~amd64 ~arm64 ~loong ~x86"
14 SRC_URI="https://download.fcitx-im.org/fcitx5/libime/libime-${PV}_dict.tar.xz"
17 DESCRIPTION="Fcitx5 Next generation of fcitx "
18 HOMEPAGE="https://fcitx-im.org/ https://gitlab.com/fcitx/libime"
20 LICENSE="BSD-1 GPL-2+ LGPL-2+ MIT"
21 SLOT="5"
22 IUSE=""
23 REQUIRED_USE=""
25 RDEPEND="app-i18n/fcitx:5"
26 DEPEND="${RDEPEND}
27 dev-libs/boost
28 kde-frameworks/extra-cmake-modules:5
29 virtual/pkgconfig"
31 src_prepare() {
32 cmake_src_prepare
33 xdg_environment_reset
36 src_configure() {
37 if [[ $(tc-get-cxx-stdlib) == libc++ ]]; then
38 append-cxxflags -D_LIBCPP_ENABLE_CXX17_REMOVED_FEATURES
41 local mycmakeargs=(
42 -DCMAKE_INSTALL_LIBDIR="${EPREFIX}/usr/$(get_libdir)"
43 -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
45 cmake_src_configure
48 src_install(){
49 cmake_src_install