dev-db/dbeaver-bin: bump version to 24.0.4
[gentoo-zh.git] / sci-chemistry / vesta / vesta-3.5.8.ebuild
blob09ea167f14bd16039f0b5720f05469216174f7d6
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit desktop xdg
8 DESCRIPTION="Visualization for Electronic and STructural Analysis"
9 HOMEPAGE="https://jp-minerals.org/vesta"
10 SRC_URI="https://jp-minerals.org/vesta/archives/${PV}/VESTA-gtk3.tar.bz2 -> ${PN}-${PV}.tar.bz2"
12 LICENSE="VESTA"
13 SLOT="0"
14 KEYWORDS="~amd64"
16 RESTRICT="mirror strip"
18 RDEPEND="
19 x11-libs/gtk+:3[wayland]
20 virtual/glu
21 dev-util/desktop-file-utils
22 x11-libs/libXtst
23 virtual/jdk
24 ${DEPEND}"
26 S="${WORKDIR}/VESTA-gtk3"
28 QA_PREBUILT="*"
30 src_install() {
31 insinto /opt/VESTA
32 doins -r *
33 fperms +x /opt/VESTA/VESTA
34 fperms +x /opt/VESTA/VESTA-gui
36 domenu "${FILESDIR}/VESTA.desktop"
38 dosym ../VESTA/VESTA /opt/bin/VESTA
39 dosym ../VESTA/VESTA /opt/bin/vesta
42 pkg_postinst() {
43 xdg_desktop_database_update
45 elog "If you meet any abnormal behavior while using VESTA after upgrade or downgrade,"
46 elog "try remove ~/.VESTA and restart VESTA. Note that this will make you lost"
47 elog "all your saved configs."
50 pkg_postrm() {
51 xdg_desktop_database_update