sys-kernel/liquorix-sources: Bump to new version, drop old version.
[gentoo-zh.git] / dev-python / structlog / structlog-21.5.0.ebuild
blobf271bfb12b9282bb1f7cfc086c5d9ef5fcf1f60f
1 # Copyright 2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 DISTUTILS_USE_PEP517=flit
7 PYTHON_COMPAT=( python3_{9,10} )
8 inherit distutils-r1
10 DESCRIPTION="Structured Logging for Python"
11 HOMEPAGE="http://www.structlog.org/en/stable/"
12 SRC_URI="https://github.com/hynek/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
14 LICENSE="Apache-2.0 MIT"
15 SLOT="0"
16 KEYWORDS="~amd64"
18 RDEPEND=""
19 BDEPEND="
20 test? (
21 dev-python/pretend[$PYTHON_USEDEP]
22 dev-python/freezegun[$PYTHON_USEDEP]
26 distutils_enable_tests pytest