Fixed cutefishos 9999 could not find build directory
[gentoo-zh.git] / cutefish-base / cutefish-wallpapers / cutefish-wallpapers-0.7.ebuild
blobbf046008796914824249bd8006b702795d9ab801
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit cmake
8 if [[ ${PV} == 9999* ]] ; then
9 inherit git-r3
10 EGIT_REPO_URI="https://github.com/cutefishos/wallpapers.git"
11 EGIT_CHECKOUT_DIR=cutefish-wallpapers-${PV}
12 KEYWORDS=""
13 else
14 EGIT_COMMIT="9acd305776a88e2a6c497c8e9b719c0f39a65c97"
15 SRC_URI="https://github.com/cutefishos/wallpapers/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
16 KEYWORDS="~amd64 ~arm64 ~riscv"
17 S="${WORKDIR}/wallpapers-${EGIT_COMMIT}"
20 DESCRIPTION="CutefishOS's system wallpaper"
21 HOMEPAGE="https://github.com/cutefishos/wallpapers"
22 LICENSE="GPL-3"
23 SLOT="0"
24 IUSE=""
25 RDEPEND=""
26 DEPEND=""
27 BDEPEND="${DEPEND}
28 kde-frameworks/extra-cmake-modules
29 dev-util/ninja
32 src_configure(){
33 mycmakeargs=(
34 -DCMAKE_INSTALL_PREFIX="/usr"
36 cmake_src_configure