app-office/anytype-bin: add 0.40.8, drop 0.39.0
[gentoo-zh.git] / app-emulation / deepin-wine-helper / deepin-wine-helper-5.1.27-r1.ebuild
blobae0d63aa82bf2bcbff720f2a57e5dcc3671d0be5
1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 PYTHON_COMPAT=( python3_{9..11} )
7 inherit python-single-r1 unpacker
9 DESCRIPTION="Deepin Wine Helper"
10 HOMEPAGE="https://www.deepin.org"
12 COMMON_URI="https://home-store-packages.uniontech.com/appstore/pool/appstore/d"
13 SRC_URI="${COMMON_URI}/${PN}/${PN}_${PV}-${PR/r/}_i386.deb"
15 LICENSE="LGPL-2.1"
16 SLOT="0"
17 KEYWORDS="~amd64"
18 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
19 RESTRICT="test"
21 RDEPEND="
22 ${PYTHON_DEPS}
23 app-emulation/deepin-wine-plugin[virtual-pkg]
25 DEPEND="${RDEPEND}"
27 S=${WORKDIR}
29 QA_PREBUILT="opt/deepinwine/*"
30 QA_FLAGS_IGNORED="opt/deepinwine/*"
32 src_install() {
33 python_fix_shebang -f "opt/deepinwine/tools/add_hotkeys"
34 python_fix_shebang -f "opt/deepinwine/tools/get_tray_window"
35 insinto /
36 doins -r opt
38 fperms 755 -R /opt/deepinwine/tools/