net-misc/tssh: add 0.1.5, drop 0.1.4
[gentoo-zh.git] / net-misc / tssh / tssh-0.1.5.ebuild
blobac93e54d5311b0ad06642c489ae8dbdefc4da6d2
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
5 inherit go-module
7 DESCRIPTION="内置支持 trzsz ( trz / tsz ) 的 ssh 客户端,支持选择( 搜索 )服务器进行登录"
8 HOMEPAGE="https://github.com/trzsz/trzsz-ssh"
10 SRC_URI="
11 https://github.com/trzsz/trzsz-ssh/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
12 https://github.com/peeweep/gentoo-go-deps/releases/download/${P}/${P}-deps.tar.xz
15 DEPEND=""
16 RDEPEND="${DEPEND}"
17 LICENSE="MIT"
18 SLOT="0"
19 KEYWORDS="~amd64 ~arm64 ~riscv"
20 IUSE=""
21 S="${WORKDIR}/trzsz-ssh-${PV}/cmd/tssh"
23 src_compile() {
24 ego build -o bin/${PN} -trimpath -ldflags "-w -s"
27 src_install() {
28 dobin bin/${PN}