*/*: breaken package drop keywords
[gentoo-zh.git] / app-text / wiznote / wiznote-2.1.14.ebuild
blob5697b91c54b6a139bbfddb8dd4eef7ed458920e1
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v3
4 EAPI=7
6 if [[ ${PV} == "9999" ]]; then
7 EGIT_REPO_URI="https://github.com/WizTeam/WizQTClient.git"
8 EGIT_BRANCH="${EGIT_MASTER}"
9 KEYWORDS=""
10 WIZNOTE_SRC_URI=""
11 WIZNOTE_ECLASS="git-r3"
12 else
13 WIZNOTE_SRC_URI="https://github.com/WizTeam/WizQTClient/archive/v${PV}.tar.gz -> ${P}.tar.gz"
14 RESTRICT="mirror"
15 WIZNOTE_ECLASS="vcs-snapshot"
16 KEYWORDS=""
19 inherit ${WIZNOTE_ECLASS} cmake-utils
21 DESCRIPTION="WizNote lets you capture anything you might to remember: create text notes, clip content from the web, snap photos and have all of these notes avaliable you on any device."
22 HOMEPAGE="http://www.wiz.cn/index.html"
23 SRC_URI="${WIZNOTE_SRC_URI}"
25 LICENSE="GPL-3"
26 SLOT="0"
27 IUSE=""
29 RDEPEND="dev-qt/qtcore:4
30 dev-qt/qtgui:4
31 dev-qt/qtwebkit:4"
32 DEPEND="${RDEPEND}"