sys-kernel/xanmod-hybrid: Update To v5.12.9 (#948)
[gentoo-zh.git] / sys-kernel / xanmod-hybrid / xanmod-hybrid-5.12.8-r1.ebuild
blob18039918be13edfacb1fa9f9cb5193831f23ca72
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI="6"
5 K_WANT_GENPATCHES="base extras"
6 K_GENPATCHES_VER="1"
7 K_SECURITY_UNSUPPORTED="1"
8 K_NOSETEXTRAVERSION="1"
9 ETYPE="sources"
10 IUSE="uksm cjktty +xanmod cacule"
11 REQUIRED_USE="^^ ( xanmod cacule )"
12 DEPEND="app-arch/cpio
13 dev-util/pahole
14 dev-libs/libbpf
16 RDEPEND="!sys-kernel/xanmod-sources"
18 inherit kernel-2-src-prepare-overlay
19 detect_version
21 DESCRIPTION="Xanmod and Xanmod-CaCule sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
22 HOMEPAGE="https://xanmod.org/"
23 LICENSE+=" CDDL"
24 SRC_URI="${KERNEL_BASE_URI}/linux-5.12.tar.xz
25 ${GENPATCHES_URI}
28 src_unpack() {
29 UNIPATCH_LIST_DEFAULT=""
30 kernel-2-src-prepare-overlay_src_unpack
33 KEYWORDS="~amd64"
35 src_prepare() {
37 if use uksm ; then
38 eapply "${FILESDIR}/v1-uksm.patch" || die
41 if use cjktty ; then
42 eapply "${FILESDIR}/v1-cjktty.patch" || die
45 if use xanmod ; then
46 eapply "${FILESDIR}/patch-5.12.8-xanmod1" || die
49 if use cacule ; then
50 eapply "${FILESDIR}/patch-5.12.8-xanmod1-cacule" || die
53 kernel-2-src-prepare-overlay_src_prepare
57 pkg_postinst() {
58 elog "MICROCODES"
59 elog "Use xanmod-sources with microcodes"
60 elog "Read https://wiki.gentoo.org/wiki/Intel_microcode"