dev-util/tauri-cli: add 1.5.7, drop 1.5.6
[gentoo-zh.git] / dev-util / tauri-cli / tauri-cli-1.5.7.ebuild
blob27e7c6f075b5be4adbff5f1905b0d26ca893a474
1 # Copyright 2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 # Autogenerated by pycargoebuild 0.12.1
6 EAPI=8
8 CRATES="
9 addr2line@0.21.0
10 adler32@1.2.0
11 adler@1.0.2
12 aead@0.5.2
13 aes-gcm@0.10.3
14 aes@0.8.3
15 ahash@0.8.6
16 aho-corasick@1.1.2
17 android-tzdata@0.1.1
18 android_system_properties@0.1.5
19 anstream@0.6.4
20 anstyle-parse@0.2.2
21 anstyle-query@1.0.0
22 anstyle-wincon@3.0.1
23 anstyle@1.0.4
24 anyhow@1.0.75
25 ar@0.9.0
26 async-trait@0.1.74
27 autocfg@1.1.0
28 axum-core@0.3.4
29 axum@0.6.20
30 backtrace@0.3.69
31 base64@0.21.5
32 base64ct@1.6.0
33 bit-set@0.5.3
34 bit-vec@0.6.3
35 bit_field@0.10.2
36 bitflags@1.3.2
37 bitflags@2.4.1
38 block-buffer@0.10.4
39 bstr@1.8.0
40 bumpalo@3.14.0
41 bytecount@0.6.7
42 bytemuck@1.14.0
43 byteorder@1.5.0
44 bytes@1.5.0
45 bzip2-sys@0.1.11+1.0.8
46 bzip2@0.4.4
47 cc@1.0.83
48 cfb@0.7.3
49 cfg-if@1.0.0
50 chrono@0.4.31
51 cipher@0.4.4
52 clap@4.4.10
53 clap_builder@4.4.9
54 clap_complete@4.4.4
55 clap_derive@4.4.7
56 clap_lex@0.6.0
57 color_quant@1.1.0
58 colorchoice@1.0.0
59 colored@2.0.4
60 common-path@1.0.0
61 console@0.15.7
62 constant_time_eq@0.1.5
63 convert_case@0.4.0
64 convert_case@0.6.0
65 core-foundation-sys@0.8.6
66 core-foundation@0.9.4
67 core2@0.4.0
68 cpufeatures@0.2.11
69 crc32fast@1.3.2
70 crossbeam-channel@0.5.8
71 crossbeam-deque@0.8.3
72 crossbeam-epoch@0.9.15
73 crossbeam-utils@0.8.16
74 crunchy@0.2.2
75 crypto-common@0.1.6
76 cssparser-macros@0.6.1
77 cssparser@0.27.2
78 ctor@0.2.5
79 ctr@0.9.2
80 ctrlc@3.4.1
81 darling@0.20.3
82 darling_core@0.20.3
83 darling_macro@0.20.3
84 dary_heap@0.3.6
85 data-encoding@2.5.0
86 deranged@0.3.9
87 derive_more@0.99.17
88 dialoguer@0.11.0
89 digest@0.10.7
90 dirs-next@2.0.0
91 dirs-sys-next@0.1.2
92 dtoa-short@0.3.4
93 dtoa@1.0.9
94 dunce@1.0.4
95 dyn-clone@1.0.16
96 either@1.9.0
97 encode_unicode@0.3.6
98 encoding_rs@0.8.33
99 env_logger@0.10.1
100 equivalent@1.0.1
101 erased-serde@0.3.31
102 errno@0.3.8
103 exr@1.71.0
104 fancy-regex@0.11.0
105 fastrand@2.0.1
106 fdeflate@0.3.1
107 filetime@0.2.22
108 flate2@1.0.28
109 flume@0.11.0
110 fnv@1.0.7
111 foreign-types-shared@0.1.1
112 foreign-types@0.3.2
113 form_urlencoded@1.2.1
114 fraction@0.13.1
115 fsevent-sys@4.1.0
116 futf@0.1.5
117 futures-channel@0.3.29
118 futures-core@0.3.29
119 futures-io@0.3.29
120 futures-sink@0.3.29
121 futures-task@0.3.29
122 futures-util@0.3.29
123 fxhash@0.2.1
124 generic-array@0.14.7
125 getrandom@0.1.16
126 getrandom@0.2.11
127 ghash@0.5.0
128 gif@0.12.0
129 gimli@0.28.1
130 glob@0.3.1
131 globset@0.4.14
132 h2@0.3.22
133 half@2.2.1
134 handlebars@4.5.0
135 hashbrown@0.12.3
136 hashbrown@0.13.2
137 hashbrown@0.14.3
138 heck@0.4.1
139 hermit-abi@0.3.3
140 hex@0.4.3
141 hmac@0.12.1
142 html5ever@0.26.0
143 http-body@0.4.5
144 http@0.2.11
145 httparse@1.8.0
146 httpdate@1.0.3
147 humantime@2.1.0
148 hyper@0.14.27
149 iana-time-zone-haiku@0.1.2
150 iana-time-zone@0.1.58
151 ident_case@1.0.1
152 idna@0.5.0
153 ignore@0.4.21
154 image@0.24.7
155 include_dir@0.7.3
156 include_dir_macros@0.7.3
157 indexmap@1.9.3
158 indexmap@2.1.0
159 infer@0.13.0
160 inotify-sys@0.1.5
161 inotify@0.9.6
162 inout@0.1.3
163 ipnet@2.9.0
164 is-terminal@0.4.9
165 iso8601@0.6.1
166 itertools@0.11.0
167 itoa@0.4.8
168 itoa@1.0.9
169 jobserver@0.1.27
170 jpeg-decoder@0.3.0
171 js-sys@0.3.66
172 json-patch@1.2.0
173 json5@0.4.1
174 jsonschema@0.17.1
175 kqueue-sys@1.0.4
176 kqueue@1.0.8
177 kuchikiki@0.8.2
178 lazy_static@1.4.0
179 lebe@0.5.2
180 libc@0.2.150
181 libflate@2.0.0
182 libflate_lz77@2.0.0
183 libloading@0.8.1
184 libredox@0.0.1
185 line-wrap@0.1.1
186 linux-raw-sys@0.4.12
187 lock_api@0.4.11
188 log@0.4.20
189 mac@0.1.1
190 markup5ever@0.11.0
191 matches@0.1.10
192 matchit@0.7.3
193 md5@0.7.0
194 memchr@2.6.4
195 memoffset@0.9.0
196 mime@0.3.17
197 minimal-lexical@0.2.1
198 minisign@0.7.3
199 miniz_oxide@0.7.1
200 mio@0.8.9
201 napi-build@2.1.0
202 napi-derive-backend@1.0.55
203 napi-derive@2.14.2
204 napi-sys@2.3.0
205 napi@2.14.1
206 native-tls@0.2.11
207 new_debug_unreachable@1.0.4
208 nix@0.27.1
209 nodrop@0.1.14
210 nom@7.1.3
211 notify-debouncer-mini@0.4.1
212 notify@6.1.1
213 num-bigint@0.4.4
214 num-cmp@0.1.0
215 num-complex@0.4.4
216 num-integer@0.1.45
217 num-iter@0.1.43
218 num-rational@0.4.1
219 num-traits@0.2.17
220 num@0.4.1
221 num_cpus@1.16.0
222 object@0.32.1
223 once_cell@1.18.0
224 opaque-debug@0.3.0
225 openssl-macros@0.1.1
226 openssl-probe@0.1.5
227 openssl-src@300.1.6+3.1.4
228 openssl-sys@0.9.96
229 openssl@0.10.60
230 ordered-float@2.10.1
231 os_info@3.7.0
232 os_pipe@1.1.4
233 parking_lot@0.12.1
234 parking_lot_core@0.9.9
235 password-hash@0.4.2
236 pbkdf2@0.11.0
237 pbkdf2@0.12.2
238 percent-encoding@2.3.1
239 pest@2.7.5
240 pest_derive@2.7.5
241 pest_generator@2.7.5
242 pest_meta@2.7.5
243 phf@0.10.1
244 phf@0.11.2
245 phf@0.8.0
246 phf_codegen@0.10.0
247 phf_codegen@0.8.0
248 phf_generator@0.10.0
249 phf_generator@0.11.2
250 phf_generator@0.8.0
251 phf_macros@0.11.2
252 phf_macros@0.8.0
253 phf_shared@0.10.0
254 phf_shared@0.11.2
255 phf_shared@0.8.0
256 pin-project-internal@1.1.3
257 pin-project-lite@0.2.13
258 pin-project@1.1.3
259 pin-utils@0.1.0
260 pkg-config@0.3.27
261 plist@1.6.0
262 png@0.17.10
263 polyval@0.6.1
264 powerfmt@0.2.0
265 ppv-lite86@0.2.17
266 precomputed-hash@0.1.1
267 proc-macro-hack@0.5.20+deprecated
268 proc-macro2@1.0.70
269 qoi@0.4.1
270 quick-xml@0.31.0
271 quote@1.0.33
272 rand@0.7.3
273 rand@0.8.5
274 rand_chacha@0.2.2
275 rand_chacha@0.3.1
276 rand_core@0.5.1
277 rand_core@0.6.4
278 rand_hc@0.2.0
279 rand_pcg@0.2.1
280 rayon-core@1.12.0
281 rayon@1.8.0
282 redox_syscall@0.3.5
283 redox_syscall@0.4.1
284 redox_users@0.4.4
285 regex-automata@0.4.3
286 regex-syntax@0.8.2
287 regex@1.10.2
288 reqwest@0.11.22
289 ring@0.17.6
290 rle-decode-fast@1.0.3
291 rpassword@7.3.1
292 rtoolbox@0.0.2
293 rustc-demangle@0.1.23
294 rustc_version@0.4.0
295 rustix@0.38.26
296 rustls-webpki@0.101.7
297 rustls@0.21.9
298 rustversion@1.0.14
299 ryu@1.0.15
300 safemem@0.3.3
301 salsa20@0.10.2
302 same-file@1.0.6
303 schannel@0.1.22
304 schemars@0.8.16
305 schemars_derive@0.8.16
306 scopeguard@1.2.0
307 scrypt@0.11.0
308 sct@0.7.1
309 security-framework-sys@2.9.1
310 security-framework@2.9.2
311 selectors@0.22.0
312 semver@1.0.20
313 serde-value@0.7.0
314 serde@1.0.193
315 serde_derive@1.0.193
316 serde_derive_internals@0.26.0
317 serde_fmt@1.0.3
318 serde_json@1.0.108
319 serde_path_to_error@0.1.14
320 serde_spanned@0.6.4
321 serde_urlencoded@0.7.1
322 serde_with@3.4.0
323 serde_with_macros@3.4.0
324 serialize-to-javascript-impl@0.1.1
325 serialize-to-javascript@0.1.1
326 servo_arc@0.1.1
327 sha1@0.10.6
328 sha1_smol@1.0.0
329 sha2@0.10.8
330 shared_child@1.0.0
331 shell-words@1.1.0
332 simd-adler32@0.3.7
333 siphasher@0.3.11
334 slab@0.4.9
335 smallvec@1.11.2
336 socket2@0.4.10
337 socket2@0.5.5
338 spin@0.9.8
339 stable_deref_trait@1.2.0
340 string_cache@0.8.7
341 string_cache_codegen@0.5.2
342 strsim@0.10.0
343 subtle@2.5.0
344 sval@2.10.2
345 sval_buffer@2.10.2
346 sval_dynamic@2.10.2
347 sval_fmt@2.10.2
348 sval_json@2.10.2
349 sval_ref@2.10.2
350 sval_serde@2.10.2
351 syn@1.0.109
352 syn@2.0.39
353 sync_wrapper@0.1.2
354 system-configuration-sys@0.5.0
355 system-configuration@0.5.1
356 tar@0.4.40
357 tauri-icns@0.1.0
358 tempfile@3.8.1
359 tendril@0.4.3
360 termcolor@1.4.0
361 thin-slice@0.1.1
362 thiserror-impl@1.0.50
363 thiserror@1.0.50
364 tiff@0.9.0
365 time-core@0.1.2
366 time-macros@0.2.15
367 time@0.3.30
368 tinyvec@1.6.0
369 tinyvec_macros@0.1.1
370 tokio-macros@2.2.0
371 tokio-tungstenite@0.20.1
372 tokio-util@0.7.10
373 tokio@1.34.0
374 toml@0.7.8
375 toml@0.8.8
376 toml_datetime@0.6.5
377 toml_edit@0.19.15
378 toml_edit@0.21.0
379 tower-layer@0.3.2
380 tower-service@0.3.2
381 tower@0.4.13
382 tracing-core@0.1.32
383 tracing@0.1.40
384 treediff@4.0.2
385 try-lock@0.2.4
386 tungstenite@0.20.1
387 typenum@1.17.0
388 ucd-trie@0.1.6
389 unicode-bidi@0.3.13
390 unicode-ident@1.0.12
391 unicode-normalization@0.1.22
392 unicode-segmentation@1.10.1
393 unicode-width@0.1.11
394 universal-hash@0.5.1
395 untrusted@0.9.0
396 ureq@2.9.1
397 url@2.5.0
398 utf-8@0.7.6
399 utf8parse@0.2.1
400 uuid@1.6.1
401 value-bag-serde1@1.4.2
402 value-bag-sval2@1.4.2
403 value-bag@1.4.2
404 vcpkg@0.2.15
405 version_check@0.9.4
406 walkdir@2.4.0
407 want@0.3.1
408 wasi@0.11.0+wasi-snapshot-preview1
409 wasi@0.9.0+wasi-snapshot-preview1
410 wasm-bindgen-backend@0.2.89
411 wasm-bindgen-futures@0.4.39
412 wasm-bindgen-macro-support@0.2.89
413 wasm-bindgen-macro@0.2.89
414 wasm-bindgen-shared@0.2.89
415 wasm-bindgen@0.2.89
416 web-sys@0.3.66
417 webpki-roots@0.25.3
418 weezl@0.1.7
419 winapi-i686-pc-windows-gnu@0.4.0
420 winapi-util@0.1.6
421 winapi-x86_64-pc-windows-gnu@0.4.0
422 winapi@0.3.9
423 windows-core@0.51.1
424 windows-sys@0.45.0
425 windows-sys@0.48.0
426 windows-sys@0.52.0
427 windows-targets@0.42.2
428 windows-targets@0.48.5
429 windows-targets@0.52.0
430 windows-version@0.1.0
431 windows_aarch64_gnullvm@0.42.2
432 windows_aarch64_gnullvm@0.48.5
433 windows_aarch64_gnullvm@0.52.0
434 windows_aarch64_msvc@0.42.2
435 windows_aarch64_msvc@0.48.5
436 windows_aarch64_msvc@0.52.0
437 windows_i686_gnu@0.42.2
438 windows_i686_gnu@0.48.5
439 windows_i686_gnu@0.52.0
440 windows_i686_msvc@0.42.2
441 windows_i686_msvc@0.48.5
442 windows_i686_msvc@0.52.0
443 windows_x86_64_gnu@0.42.2
444 windows_x86_64_gnu@0.48.5
445 windows_x86_64_gnu@0.52.0
446 windows_x86_64_gnullvm@0.42.2
447 windows_x86_64_gnullvm@0.48.5
448 windows_x86_64_gnullvm@0.52.0
449 windows_x86_64_msvc@0.42.2
450 windows_x86_64_msvc@0.48.5
451 windows_x86_64_msvc@0.52.0
452 winnow@0.5.19
453 winreg@0.50.0
454 winreg@0.51.0
455 xattr@1.0.1
456 zerocopy-derive@0.7.27
457 zerocopy@0.7.27
458 zeroize@1.7.0
459 zip@0.6.6
460 zstd-safe@5.0.2+zstd.1.5.2
461 zstd-sys@2.0.9+zstd.1.5.5
462 zstd@0.11.2+zstd.1.5.2
463 zune-inflate@0.2.54
466 inherit cargo
468 DESCRIPTION="Command line interface for building Tauri apps"
469 HOMEPAGE="https://tauri.app"
470 SRC_URI="
471 https://github.com/tauri-apps/tauri/archive/refs/tags/tauri-cli-v${PV}.tar.gz
472 ${CARGO_CRATE_URIS}
474 S="${WORKDIR}/tauri-tauri-cli-v${PV}/tooling/cli"
476 LICENSE="|| ( Apache-2.0 MIT )"
477 # Dependent crate licenses
478 LICENSE+=" Apache-2.0 BSD CC0-1.0 ISC MIT MPL-2.0 Unicode-DFS-2016 ZLIB"
479 SLOT="0"
480 KEYWORDS="~amd64"