dev-util/android-studio: new package, add 2023.2.1.25
[gentoo-zh.git] / app-i18n / ibus-rime / ibus-rime-9999.ebuild
blob817ca84bdc96a887378c1b921b53b61d775c7b06
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit git-r3
8 DESCRIPTION="Rime Input Method Engine for IBus Framework"
9 HOMEPAGE="http://code.google.com/p/rimeime/"
10 EGIT_REPO_URI="https://github.com/lotem/${PN}.git"
12 LICENSE="GPL-3"
13 SLOT="0"
15 COMMON_DEPEND="app-i18n/ibus
16 app-i18n/librime
17 x11-libs/libnotify"
18 DEPEND="${COMMON_DEPEND}
19 dev-build/cmake"
20 RDEPEND="${COMMON_DEPEND}
21 app-i18n/rime-data"
23 src_prepare() {
24 sed -i -e "/libexecdir/s:/usr/lib:/usr/libexec:" Makefile || die
25 sed -i -e "/exec/s:/usr/lib:/usr/libexec:" rime.xml || die