dev-vcs/gptcommit: add 0.5.13, drop 0.5.11
[gentoo-zh.git] / dev-vcs / gptcommit / gptcommit-0.5.13.ebuild
blob5bfa8ac06aec368583bf074711b1a5695ce37140
1 # Copyright 2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 # Auto-Generated by cargo-ebuild 0.5.4
6 EAPI=8
8 CRATES="
9 addr2line-0.21.0
10 adler-1.0.2
11 ahash-0.7.6
12 aho-corasick-1.0.5
13 alloc-no-stdlib-2.0.4
14 alloc-stdlib-0.2.2
15 anstream-0.5.0
16 anstyle-1.0.2
17 anstyle-parse-0.2.1
18 anstyle-query-1.0.0
19 anstyle-wincon-2.1.0
20 anyhow-1.0.75
21 async-channel-1.9.0
22 async-compression-0.4.2
23 async-convert-1.0.0
24 async-executor-1.5.1
25 async-global-executor-2.3.1
26 async-io-1.13.0
27 async-lock-2.8.0
28 async-openai-0.14.0
29 async-std-1.12.0
30 async-task-4.4.0
31 async-trait-0.1.73
32 atomic-waker-1.1.1
33 autocfg-1.1.0
34 backoff-0.4.0
35 backtrace-0.3.69
36 base64-0.13.1
37 base64-0.21.3
38 bitflags-1.3.2
39 bitflags-2.4.0
40 bit-set-0.5.3
41 bit-vec-0.6.3
42 block-buffer-0.10.4
43 blocking-1.3.1
44 brotli-3.3.4
45 brotli-decompressor-2.3.4
46 bstr-0.2.17
47 bstr-1.6.2
48 bumpalo-3.13.0
49 bytes-1.4.0
50 cc-1.0.83
51 cfg-if-1.0.0
52 clap-4.4.2
53 clap_builder-4.4.2
54 clap_derive-4.4.2
55 clap_lex-0.5.1
56 colorchoice-1.0.0
57 colored-2.0.4
58 concurrent-queue-2.2.0
59 config-0.13.3
60 core-foundation-0.9.3
61 core-foundation-sys-0.8.4
62 cpufeatures-0.2.9
63 crc32fast-1.3.2
64 crossbeam-utils-0.8.16
65 crypto-common-0.1.6
66 darling-0.14.4
67 darling_core-0.14.4
68 darling_macro-0.14.4
69 deranged-0.3.8
70 derive_builder-0.12.0
71 derive_builder_core-0.12.0
72 derive_builder_macro-0.12.0
73 digest-0.10.7
74 dirs-5.0.1
75 dirs-sys-0.4.1
76 dlv-list-0.3.0
77 either-1.9.0
78 encoding_rs-0.8.33
79 equivalent-1.0.1
80 errno-0.3.3
81 errno-dragonfly-0.1.2
82 event-listener-2.5.3
83 eventsource-stream-0.2.3
84 fancy-regex-0.11.0
85 fastrand-1.9.0
86 flate2-1.0.27
87 fnv-1.0.7
88 form_urlencoded-1.2.0
89 futures-0.3.28
90 futures-channel-0.3.28
91 futures-core-0.3.28
92 futures-executor-0.3.28
93 futures-io-0.3.28
94 futures-lite-1.13.0
95 futures-macro-0.3.28
96 futures-sink-0.3.28
97 futures-task-0.3.28
98 futures-timer-3.0.2
99 futures-util-0.3.28
100 generic-array-0.14.7
101 getrandom-0.2.10
102 gimli-0.28.0
103 globset-0.4.13
104 globwalk-0.8.1
105 gloo-timers-0.2.6
106 h2-0.3.21
107 hashbrown-0.12.3
108 hashbrown-0.14.0
109 heck-0.4.1
110 hermit-abi-0.3.2
111 http-0.2.9
112 httparse-1.8.0
113 http-body-0.4.5
114 httpdate-1.0.3
115 hyper-0.14.27
116 hyper-rustls-0.24.1
117 ident_case-1.0.1
118 idna-0.4.0
119 ignore-0.4.20
120 indexmap-1.9.3
121 indexmap-2.0.0
122 instant-0.1.12
123 io-lifetimes-1.0.11
124 ipnet-2.8.0
125 is-terminal-0.4.9
126 itoa-1.0.9
127 json5-0.4.1
128 js-sys-0.3.64
129 kv-log-macro-1.0.7
130 lazy_static-1.4.0
131 libc-0.2.147
132 linked-hash-map-0.5.6
133 linux-raw-sys-0.3.8
134 linux-raw-sys-0.4.5
135 lock_api-0.4.10
136 log-0.4.20
137 memchr-2.6.2
138 mime-0.3.17
139 mime_guess-2.0.4
140 minimal-lexical-0.2.1
141 miniz_oxide-0.7.1
142 mio-0.8.8
143 nom-7.1.3
144 num_cpus-1.16.0
145 num_threads-0.1.6
146 object-0.32.0
147 once_cell-1.18.0
148 openssl-probe-0.1.5
149 option-ext-0.2.0
150 ordered-multimap-0.4.3
151 parking-2.1.0
152 parking_lot-0.12.1
153 parking_lot_core-0.9.8
154 pathdiff-0.2.1
155 percent-encoding-2.3.0
156 pest-2.7.3
157 pest_derive-2.7.3
158 pest_generator-2.7.3
159 pest_meta-2.7.3
160 pin-project-lite-0.2.13
161 pin-utils-0.1.0
162 polling-2.8.0
163 ppv-lite86-0.2.17
164 proc-macro2-1.0.66
165 quote-1.0.33
166 rand-0.8.5
167 rand_chacha-0.3.1
168 rand_core-0.6.4
169 redox_syscall-0.2.16
170 redox_syscall-0.3.5
171 redox_users-0.4.3
172 regex-1.9.4
173 regex-automata-0.1.10
174 regex-automata-0.3.7
175 regex-syntax-0.7.5
176 reqwest-0.11.20
177 reqwest-eventsource-0.4.0
178 ring-0.16.20
179 ron-0.7.1
180 rustc-demangle-0.1.23
181 rustc-hash-1.1.0
182 rust-ini-0.18.0
183 rustix-0.37.23
184 rustix-0.38.11
185 rustls-0.21.7
186 rustls-native-certs-0.6.3
187 rustls-pemfile-1.0.3
188 rustls-webpki-0.101.4
189 rustversion-1.0.14
190 ryu-1.0.15
191 same-file-1.0.6
192 schannel-0.1.22
193 scopeguard-1.2.0
194 sct-0.7.0
195 security-framework-2.9.2
196 security-framework-sys-2.9.1
197 serde-1.0.188
198 serde_derive-1.0.188
199 serde_json-1.0.105
200 serde_spanned-0.6.3
201 serde_urlencoded-0.7.1
202 sha2-0.10.7
203 signal-hook-registry-1.4.1
204 simple_logger-4.2.0
205 slab-0.4.9
206 smallvec-1.11.0
207 socket2-0.4.9
208 socket2-0.5.3
209 spin-0.5.2
210 strsim-0.10.0
211 strum-0.25.0
212 strum_macros-0.25.2
213 syn-1.0.109
214 syn-2.0.29
215 tera-1.19.0
216 thiserror-1.0.47
217 thiserror-impl-1.0.47
218 thread_local-1.1.4
219 tiktoken-rs-0.5.3
220 time-0.3.28
221 time-core-0.1.1
222 time-macros-0.2.14
223 tinyvec-1.6.0
224 tinyvec_macros-0.1.1
225 tokio-1.32.0
226 tokio-macros-2.1.0
227 tokio-rustls-0.24.1
228 tokio-socks-0.5.1
229 tokio-stream-0.1.14
230 tokio-util-0.7.8
231 toml-0.5.11
232 toml-0.7.6
233 toml_datetime-0.6.3
234 toml_edit-0.19.14
235 tower-service-0.3.2
236 tracing-0.1.37
237 tracing-attributes-0.1.26
238 tracing-core-0.1.31
239 try-lock-0.2.4
240 typenum-1.16.0
241 ucd-trie-0.1.6
242 unicase-2.7.0
243 unic-char-property-0.9.0
244 unic-char-range-0.9.0
245 unic-common-0.9.0
246 unicode-bidi-0.3.13
247 unicode-ident-1.0.11
248 unicode-normalization-0.1.22
249 unic-segment-0.9.0
250 unic-ucd-segment-0.9.0
251 unic-ucd-version-0.9.0
252 untrusted-0.7.1
253 url-2.4.1
254 utf8parse-0.2.1
255 value-bag-1.4.1
256 version_check-0.9.4
257 waker-fn-1.1.0
258 walkdir-2.3.3
259 want-0.3.1
260 wasi-0.11.0+wasi-snapshot-preview1
261 wasm-bindgen-0.2.87
262 wasm-bindgen-backend-0.2.87
263 wasm-bindgen-futures-0.4.37
264 wasm-bindgen-macro-0.2.87
265 wasm-bindgen-macro-support-0.2.87
266 wasm-bindgen-shared-0.2.87
267 wasm-streams-0.3.0
268 webpki-roots-0.25.2
269 web-sys-0.3.64
270 which-4.4.0
271 winapi-0.3.9
272 winapi-i686-pc-windows-gnu-0.4.0
273 winapi-util-0.1.5
274 winapi-x86_64-pc-windows-gnu-0.4.0
275 windows_aarch64_gnullvm-0.42.2
276 windows_aarch64_gnullvm-0.48.5
277 windows_aarch64_msvc-0.42.2
278 windows_aarch64_msvc-0.48.5
279 windows_i686_gnu-0.42.2
280 windows_i686_gnu-0.48.5
281 windows_i686_msvc-0.42.2
282 windows_i686_msvc-0.48.5
283 windows-sys-0.42.0
284 windows-sys-0.48.0
285 windows-targets-0.48.5
286 windows_x86_64_gnu-0.42.2
287 windows_x86_64_gnu-0.48.5
288 windows_x86_64_gnullvm-0.42.2
289 windows_x86_64_gnullvm-0.48.5
290 windows_x86_64_msvc-0.42.2
291 windows_x86_64_msvc-0.48.5
292 winnow-0.5.15
293 winreg-0.50.0
294 yaml-rust-0.4.5
297 inherit cargo
299 DESCRIPTION="A git prepare-commit-msg hook for summarizing commits with GPT-3."
300 HOMEPAGE="https://github.com/zurawiki/gptcommit"
301 SRC_URI="
302 https://github.com/zurawiki/gptcommit/archive/tags/v${PV}.tar.gz -> ${P}.tar.gz
303 $(cargo_crate_uris)
305 S="${WORKDIR}/gptcommit-tags-v${PV}"
307 LICENSE="0BSD Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD Boost-1.0 ISC MIT MPL-2.0 Unicode-DFS-2016 Unlicense ZLIB"
308 SLOT="0"
309 KEYWORDS="~amd64 ~arm64"
311 DEPEND=""
312 RDEPEND="${DEPEND}"
313 BDEPEND=""