app-emulation/proton-ge-custom-bin and virtual/proton-ge-custom-meta:
[gentoo-zh.git] / sys-kernel / liquorix-sources / liquorix-sources-5.16.12.ebuild
blob6c60a96bd9836372c849c83ac5e4c216c4edb9ed
1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 # Define what default functions to run
7 ETYPE="sources"
9 # No 'experimental' USE flag provided, but we still want to use genpatches
10 K_EXP_GENPATCHES_NOUSE="1"
12 # Just get basic genpatches, -lqx patch set already includes main updates
13 K_GENPATCHES_VER="1"
15 # -lqx already sets EXTRAVERSION to kernel Makefile
16 K_NOSETEXTRAVERSION="1"
18 # Not supported by the Gentoo security team
19 K_SECURITY_UNSUPPORTED="1"
21 # We want the very basic patches from gentoo-sources, experimental patch is
22 # already included in liquorix-sources
23 K_WANT_GENPATCHES="base extras"
25 # To use CJKTTY, Please enable this USE
26 IUSE="+cjk"
28 DEPEND="
29 app-arch/cpio
30 dev-util/pahole"
32 inherit kernel-2
33 detect_version
35 DESCRIPTION="Liquorix kernel is best one for desktop, multimedia and gaming workloads"
36 HOMEPAGE="https://liquorix.net/"
38 SRC_URI="
39 ${KERNEL_BASE_URI}/linux-${KV_MAJOR}.${KV_MINOR}.tar.xz
40 ${GENPATCHES_URI}
41 https://github.com/zen-kernel/zen-kernel/releases/download/v${PV}-lqx1/v${PV}-lqx1.patch.xz
42 https://github.com/zhmars/cjktty-patches/raw/master/v${KV_MAJOR}.x/cjktty-${KV_MAJOR}.${KV_MINOR}.patch"
44 KEYWORDS="~amd64"
46 S="${WORKDIR}/linux-${PVR}-liquorix"
48 K_EXTRAEINFO="For more info on liquorix-kernel and details on how to report problems, see: ${HOMEPAGE}."
50 src_unpack() {
51 UNIPATCH_LIST_DEFAULT="${DISTDIR}/v${PV}-lqx1.patch.xz"
52 UNIPATCH_LIST=""
53 if use cjk; then
54 UNIPATCH_LIST+="${DISTDIR}/cjktty-${KV_MAJOR}.${KV_MINOR}.patch"
57 kernel-2_src_unpack