dev-libs/v2ray-geoip-bin: add 202306010100, drop 202211030059
[gentoo-zh.git] / dev-python / fuo-local / fuo-local-0.3.ebuild
blobcb0d84e6a7068b9d4689f563f015d633a5d8be7c
1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
5 PYTHON_COMPAT=( python3_{9..11} )
7 inherit distutils-r1
9 DESCRIPTION="local music support for feeluown"
10 HOMEPAGE="https://github.com/feeluown/feeluown-local"
11 MY_P="${P/-/_}"
12 S="${WORKDIR}/${MY_P}"
13 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
15 LICENSE="GPL-3"
16 SLOT="0"
17 KEYWORDS="~amd64"
19 RDEPEND="
20 dev-python/marshmallow[${PYTHON_USEDEP}]
21 dev-python/fuzzywuzzy[${PYTHON_USEDEP}]
22 media-libs/mutagen[${PYTHON_USEDEP}]
25 PDEPEND="
26 media-sound/feeluown
29 python_install_all() {
30 distutils-r1_python_install_all