net-misc/tssh: add 0.1.2, drop 0.1.1
[gentoo-zh.git] / app-misc / ccal / ccal-2.5.3.ebuild
blob86fbfeeedba9173262dca240a6ce69782873c0bd
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI="7"
6 inherit eutils toolchain-funcs
8 DESCRIPTION="A simple command line calendar for Chinese lunar"
9 HOMEPAGE="http://ccal.chinesebay.com/ccal/ccal.htm"
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="amd64 ~arm ~arm64 ~mips x86"
14 IUSE="pdf"
15 SRC_URI="http://ccal.chinesebay.com/${PN}/${P}.tar.gz"
16 RESTRICT="mirror"
18 RDEPEND="
19 pdf? ( app-text/ghostscript-gpl )"
21 PATCHES=( "${FILESDIR}/${PN}-cflags.patch" )
23 src_prepare() {
24 default
25 sed -i "s/^CXX=.*$/CXX=$(tc-getCXX)/" Makefile || die
28 src_install() {
29 use pdf && ( dobin ccalpdf; doman ccalpdf.1 )
30 dobin ccal
31 doman ccal.1