Add Alephone.
[gentoo-soor-overlay.git] / games-fps / alephone / alephone-20071103-r1.ebuild
blob2cea89a528f015d2b5a08a0a2e67c490798025ca
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/alephone-20071103.ebuild,v 1.1 2008/02/04 22:32:29 mr_bones_ Exp $
5 inherit autotools eutils games
7 DESCRIPTION="An enhanced version of the game engine from the classic Mac game, Marathon"
8 HOMEPAGE="http://source.bungie.org/"
9 SRC_URI="mirror://sourceforge/marathon/AlephOne-${PV}-nolibs.tar.bz2"
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~ppc64 ~x86"
14 IUSE="lua mad opengl smpeg sndfile speex vorbis"
16 RDEPEND="opengl? ( virtual/opengl )
17 speex? ( media-libs/speex )
18 mad? ( media-libs/libmad )
19 vorbis? ( media-libs/libvorbis )
20 sndfile? ( media-libs/libsndfile )
21 smpeg? ( media-libs/smpeg )
22 media-libs/sdl-net
23 media-libs/sdl-image
24 media-libs/libsdl
25 media-libs/alsa-lib"
26 DEPEND="${RDEPEND}
27 dev-libs/boost"
29 S=${WORKDIR}/AlephOne-${PV}
31 src_unpack() {
32 unpack ${A}
33 cd "${S}"
34 use speex && epatch "${FILESDIR}"/alephone-20071103-speex-1.2.patch
35 sed "s:GAMES_DATADIR:${GAMES_DATADIR}:g" \
36 "${FILESDIR}"/${PN}.sh > "${T}"/${PN}.sh \
37 || die "sed failed"
40 src_compile() {
41 egamesconf \
42 --disable-dependency-tracking \
43 $(use_enable lua) \
44 $(use_enable mad) \
45 $(use_enable opengl) \
46 $(use_enable smpeg) \
47 $(use_enable sndfile) \
48 $(use_enable speex) \
49 $(use_enable vorbis) \
50 || die
51 emake || die "emake failed"
54 src_install() {
55 emake DESTDIR="${D}" install || die "emake install failed"
56 dogamesbin "${T}"/${PN}.sh || die "dogamesbin failed"
57 dodoc AUTHORS ChangeLog README docs/Cheat_Codes
58 dohtml docs/MML.html
59 prepgamesdirs
62 pkg_postinst() {
63 games_pkg_postinst
64 echo
65 elog "Read the docs and install the data files accordingly to play."
66 echo
67 elog "If you only want to install one scenario, read"
68 elog "http://traxus.jjaro.net/traxus/AlephOne:Install_Guide#Single_scenario_3"
69 elog "If you want to install multiple scenarios, read"
70 elog "http://traxus.jjaro.net/traxus/AlephOne:Install_Guide#Multiple_scenarios_3"
71 echo