kde-misc/krusader: didn't need that QT4_BUILT_WITH_USE_CHECK line ...
[gentoo-soor-overlay.git] / x11-libs / qt-webkit / qt-webkit-4.4.0_rc1.ebuild
blob3657c26e3a80c0211f7c8f09e2f6ae33f50a20dc
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="1"
6 inherit qt4-qt-copy
8 DESCRIPTION="The Webkit module for the Qt toolkit."
9 HOMEPAGE="http://www.trolltech.com/"
11 LICENSE="|| ( QPL-1.0 GPL-3 GPL-2 )"
12 SLOT="4"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
16 DEPEND="~x11-libs/qt-gui-${PV}"
17 RDEPEND="${DEPEND}"
19 QT4_TARGET_DIRECTORIES="src/3rdparty/webkit/WebCore tools/designer/src/plugins/qwebview"
20 QT4_EXTRACT_DIRECTORIES="src/3rdparty/webkit src/3rdparty/sqlite"
21 QCONFIG_ADD="webkit"
22 QCONFIG_DEFINE="QT_WEBKIT"
24 src_compile() {
25 local myconf
26 myconf="${myconf} -webkit"
28 qt4-build_src_compile