kde-misc/krusader: didn't need that QT4_BUILT_WITH_USE_CHECK line ...
[gentoo-soor-overlay.git] / x11-libs / qt-svg / qt-svg-4.4.0_rc1.ebuild
bloba367ee7b47758bda5b4fa1097694947ecc92b963
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="1"
6 inherit qt4-qt-copy
8 DESCRIPTION="The SVG module for the Qt toolkit."
9 HOMEPAGE="http://www.trolltech.com/"
11 LICENSE="|| ( QPL-1.0 GPL-3 GPL-2 )"
12 SLOT="4"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
16 DEPEND="~x11-libs/qt-gui-${PV}"
17 RDEPEND="${DEPEND}"
19 QCONFIG_ADD="svg"
20 QCONFIG_DEFINE="QT_SVG"
21 QT4_TARGET_DIRECTORIES="
22 src/svg
23 src/plugins/imageformats/svg
24 src/plugins/iconengines/svgiconengine"
26 src_compile() {
27 local myconf
28 myconf="${myconf} -svg -no-xkb -no-tablet -no-fontconfig -no-xrender -no-xrandr
29 -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
30 -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
31 -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
32 -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
33 -no-fontconfig -no-glib -no-opengl"
35 qt4-build_src_compile