app-office/lyx: this should fix the autoHELL stuff necessary to build
[gentoo-soor-overlay.git] / app-office / lyx / lyx-9999.ebuild
blob895bdb8e842b692d5055bb566fa86143d30bfe3e
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="1"
7 inherit autotools subversion eutils flag-o-matic font toolchain-funcs
9 FONT_P="latex-xft-fonts-0.1"
11 DESCRIPTION="WYSIWYM frontend for LaTeX, DocBook, etc."
12 HOMEPAGE="http://www.lyx.org/"
13 ESVN_REPO_URI="svn://svn.lyx.org/lyx/lyx-devel/trunk"
14 SRC_URI="ftp://ftp.lyx.org/pub/lyx/contrib/${FONT_P}.tar.gz
15 linguas_he? (
16 http://cs.haifa.ac.il/~dekelts/lyx/files/hebrew.bind
17 http://cs.haifa.ac.il/~dekelts/lyx/files/preferences
20 LICENSE="GPL-2"
21 SLOT="0"
22 KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
23 IUSE="cups debug nls pch linguas_he latex"
24 RESTRICT="test"
26 RDEPEND="|| (
28 x11-libs/qt-core:4
29 x11-libs/qt-gui:4
31 =x11-libs/qt-4.3*
33 x11-libs/libXrandr
34 x11-libs/libXcursor
35 x11-libs/libXrender
36 x11-libs/libXfixes
37 x11-libs/libXext
38 x11-libs/libSM
39 x11-libs/libICE
40 x11-libs/libX11
41 x11-libs/libXau
42 x11-libs/libXdmcp
43 media-gfx/imagemagick
44 media-libs/libpng
45 media-libs/fontconfig
46 media-libs/freetype
47 dev-libs/libxml2
48 dev-libs/boost
49 app-text/aiksaurus
50 app-text/sgmltools-lite
51 virtual/aspell-dict
52 virtual/python
53 cups? ( virtual/lpr )
54 latex? (
55 virtual/latex-base
56 virtual/ghostscript
57 app-text/noweb
58 dev-tex/dvipost
59 dev-tex/chktex
60 || (
61 dev-tex/latex2html
62 dev-tex/tth
63 dev-tex/hevea
64 dev-tex/tex4ht
67 linguas_he? ( dev-tex/ivritex )"
69 DEPEND="${RDEPEND}
70 x11-proto/xproto
71 nls? ( sys-devel/gettext )"
73 S="${WORKDIR}"/${P}
75 src_unpack() {
76 subversion_fetch || die "Fetch with SVN failed kthnx."
77 unpack ${A}
78 cd "${S}"
79 epatch "${FILESDIR}"/${PN}-1.5.0-gentoo.patch || die
82 src_compile() {
83 append-flags "$(test-flags -fno-stack-protector -fno-stack-protector-all)"
84 replace-flags "-Os" "-O2"
85 tc-export CXX
87 unset LINGUAS
89 # trunk needs to regen with autotools
90 # lets use gentoo tools instead of the lyx script,
91 # which calls aclocal, autoheader, automake, autoconf
92 AT_M4DIR="-I m4 -I config"
93 rm -rf "${S}"/autom4te.cache
94 eaclocal
95 eautoheader
96 eautomake --foreign
97 eautoconf
99 econf \
100 $(use_enable nls) \
101 $(use_enable debug) \
102 $(use_enable pch) \
103 --with-aspell --without-included-boost || die "econf failed"
104 emake || die "emake failed"
107 src_install() {
108 local mylinguas="${LINGUAS}"
110 unset LINGUAS
111 emake DESTDIR="${D}" install || die "emake install failed"
113 LINGUAS="${mylinguas}"
115 dodoc ANNOUNCE ChangeLog NEWS README RELEASE-NOTES UPGRADING
117 if use linguas_he ; then
118 insinto /usr/share/lyx/bind
119 doins "${DISTDIR}"/hebrew.bind
120 dodoc "${DISTDIR}"/preferences
123 domenu "${FILESDIR}"/lyx.desktop
125 cd "${WORKDIR}"/${FONT_P}
126 emake DESTDIR="${D}" install || die "Font installation failed"
128 font_src_install
130 if use latex ; then
131 dosym ../../../lyx/tex /usr/share/texmf/tex/latex/lyx
135 pkg_postinst() {
136 font_pkg_postinst
138 if use latex ; then
139 texhash
142 if use linguas_he ; then
143 elog
144 elog "How to use Hebrew in LyX:"
145 elog "bunzip2 /usr/share/doc/${PF}/preferences.bz2 into ~/.lyx/preferences"
146 elog "or, read http://cs.haifa.ac.il/~dekelts/lyx/instructions2.html"
147 elog "for instructions on using lyx's own preferences dialog to equal effect."
148 elog
151 elog
152 elog "There are known issues in the case of 1.4->1.5 config files transition."
153 elog "In case your File->Export list is incomplete try reconfiguring or even"
154 elog "remove the old configuration files in ~/.lyx ."
155 elog
158 pkg_postrm() {
159 if use latex ; then
160 texhash