eclass/qt4-qt-copy.eclass: I HATE EPATCH KTHNXBAI.
[gentoo-soor-overlay.git] / x11-libs / libXft / libXft-2.1.12.ebuild
blobc0b83dd3582ba256825c8f3b803a6c40dacfc920
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="1"
7 inherit x-modular flag-o-matic
9 DESCRIPTION="X.Org Xft library"
11 KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
13 IUSE="+newspr"
15 RDEPEND="x11-libs/libXrender
16 x11-libs/libX11
17 x11-libs/libXext
18 x11-proto/xproto
19 newspr? (
20 >=media-libs/freetype-2.3.5-r2
21 >=media-libs/fontconfig-2.5.0-r1
23 !newspr? (
24 media-libs/freetype:2
25 >=media-libs/fontconfig-2.2
27 DEPEND="${RDEPEND}"
29 pkg_setup() {
30 if use newspr && \
31 ! built_with_use --missing false media-libs/fontconfig ubuntu; then
32 eerror "You need to rebuild fontconfig with ubuntu USE enabled"
33 eerror "before you can compile libXft with newspr."
34 die "Please rebuild fontconfig with ubuntu enabled."
37 # No such function yet
38 # x-modular_pkg_setup
40 # (#125465) Broken with Bdirect support
41 filter-flags -Wl,-Bdirect
42 filter-ldflags -Bdirect
43 filter-ldflags -Wl,-Bdirect
45 src_unpack() {
46 unpack ${A}
47 cd "${S}"/src
48 if use newspr; then
49 epatch "${FILESDIR}"/${PN}-dont_interfere_with_newspr.patch.bz2 || die
53 pkg_postinst() {
54 elog "DO NOT report bugs to Gentoo's bugzilla"
55 elog "See http://forums.gentoo.org/viewtopic-t-511382.html for support topic on Gentoo forums."