Convert to EAPI=1
[gentoo-soor-overlay.git] / x11-libs / libXft / libXft-2.1.12.ebuild
blobb8a9853069787358db4b2e43b352af16117259e5
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="1"
6 inherit x-modular flag-o-matic
8 DESCRIPTION="X.Org Xft library"
10 KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
12 IUSE="+newspr"
14 RDEPEND="x11-libs/libXrender
15 x11-libs/libX11
16 x11-libs/libXext
17 x11-proto/xproto
18 newspr? ( >=media-libs/freetype-2.3.5-r2 )
19 !newspr? ( media-libs/freetype )
20 >=media-libs/fontconfig-2.2"
21 DEPEND="${RDEPEND}"
23 pkg_setup() {
24 # No such function yet
25 # x-modular_pkg_setup
27 # (#125465) Broken with Bdirect support
28 filter-flags -Wl,-Bdirect
29 filter-ldflags -Bdirect
30 filter-ldflags -Wl,-Bdirect
32 src_unpack() {
33 unpack ${A}
34 cd "${S}"/src
35 if use newspr; then
36 epatch "${FILESDIR}"/${PN}-dont_interfere_with_newspr.patch.bz2 || die
40 pkg_postinst() {
41 elog "DO NOT report bugs to Gentoo's bugzilla"
42 elog "See http://forums.gentoo.org/viewtopic-t-511382.html for support topic on Gentoo forums."