app-misc/gnome-commander: more work on 1.3.0.99
[gentoo-soor-overlay.git] / x11-libs / qt-script / qt-script-4.4.0_rc1.ebuild
blob95390adfcd5b88cd09501264fdbc63c310b55523
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="1"
6 inherit qt4-qt-copy
8 DESCRIPTION="The ECMAScript module for the Qt toolkit"
9 HOMEPAGE="http://www.trolltech.com/"
11 LICENSE="|| ( QPL-1.0 GPL-3 GPL-2 )"
12 SLOT="4"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
16 DEPEND="~x11-libs/qt-core-${PV}"
17 RDEPEND="${DEPEND}"
19 QT4_TARGET_DIRECTORIES="src/script/"
20 QT4_EXTRACT_DIRECTORIES="
21 include/Qt/
22 include/QtCore/
23 include/QtScript/
24 src/corelib/global/
25 src/corelib/kernel/
26 src/corelib/plugin/"
28 src_compile() {
29 local myconf
30 myconf="${myconf} -no-xkb -no-tablet -no-fontconfig -no-xrender -no-xrandr
31 -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
32 -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
33 -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
34 -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
35 -no-fontconfig -no-glib -no-opengl -no-svg"
37 qt4-build_src_compile