app-office/lyx: -9999 add release-type configuration, monolithic-build
[gentoo-soor-overlay.git] / app-office / lyx / lyx-9999.ebuild
blob51214f5511391666b8f8b89cfcfd716aa183422c
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="1"
7 inherit autotools subversion eutils flag-o-matic font toolchain-funcs
9 FONT_P="latex-xft-fonts-0.1"
11 DESCRIPTION="WYSIWYM frontend for LaTeX, DocBook, etc."
12 HOMEPAGE="http://www.lyx.org/"
13 ESVN_REPO_URI="svn://svn.lyx.org/lyx/lyx-devel/trunk"
14 SRC_URI="ftp://ftp.lyx.org/pub/lyx/contrib/${FONT_P}.tar.gz
15 linguas_he? (
16 http://cs.haifa.ac.il/~dekelts/lyx/files/hebrew.bind
17 http://cs.haifa.ac.il/~dekelts/lyx/files/preferences
20 LICENSE="GPL-2"
21 SLOT="0"
22 KEYWORDS=""
23 IUSE="cups debug latex monolithic nls pch linguas_he"
24 RESTRICT="test"
26 RDEPEND="|| (
28 x11-libs/qt-core:4
29 x11-libs/qt-gui:4
31 =x11-libs/qt-4.3*
32 =x11-libs/qt-4.2*
34 x11-libs/libXrandr
35 x11-libs/libXcursor
36 x11-libs/libXrender
37 x11-libs/libXfixes
38 x11-libs/libXext
39 x11-libs/libSM
40 x11-libs/libICE
41 x11-libs/libX11
42 x11-libs/libXau
43 x11-libs/libXdmcp
44 media-gfx/imagemagick
45 media-libs/libpng
46 media-libs/fontconfig
47 media-libs/freetype
48 dev-libs/libxml2
49 dev-libs/boost
50 >=sys-devel/gcc-4.1
51 app-text/aiksaurus
52 app-text/sgmltools-lite
53 virtual/aspell-dict
54 virtual/python
55 cups? ( virtual/lpr )
56 latex? (
57 virtual/latex-base
58 virtual/ghostscript
59 app-text/noweb
60 dev-tex/dvipost
61 dev-tex/chktex
62 || (
63 dev-tex/latex2html
64 dev-tex/tth
65 dev-tex/hevea
66 dev-tex/tex4ht
69 linguas_he? ( dev-tex/ivritex )"
71 DEPEND="${RDEPEND}
72 x11-proto/xproto
73 nls? ( sys-devel/gettext )"
75 S="${WORKDIR}"/${P}
77 src_unpack() {
78 unpack ${A}
79 subversion_fetch || die "Fetch with SVN failed kthnx."
80 cd "${S}"
81 epatch "${FILESDIR}"/${PN}-1.5.0-gentoo.patch || die
83 # trunk needs to regen with autotools
84 # lets use gentoo tools instead of the lyx script,
85 # which calls aclocal, autoheader, automake, autoconf
86 rm -rf "${S}"/autom4te.cache
87 eaclocal
88 eautoheader
89 eautomake
90 eautoconf
93 src_compile() {
94 append-flags "$(test-flags -fno-stack-protector -fno-stack-protector-all)"
95 replace-flags "-Os" "-O2"
96 tc-export CXX
98 unset LINGUAS
100 if use monolithic; then
101 monolithic="--enable-monolithic-client"
102 monolithic="${monolithic} --enable-monolithic-insets"
103 monolithic="${monolithic} --enable-monolithic-mathed"
104 monolithic="${monolithic} --enable-monolithic-core"
105 monolithic="${monolithic} --enable-monolithic-tex2lyx"
106 monolithic="${monolithic} --enable-monolithic-frontend-qt4"
109 if use debug; then
110 build_type="--enable-build-type=development"
111 else
112 build_type="--enable-build-type=release"
115 econf ${monolithic} \
116 $(use_enable nls) \
117 $(use_enable debug) \
118 $(use_enable pch) \
119 ${build_type} \
120 --with-aspell --without-included-boost || die "econf failed"
121 emake || die "emake failed"
124 src_install() {
125 local mylinguas="${LINGUAS}"
127 unset LINGUAS
128 emake DESTDIR="${D}" install || die "emake install failed"
130 LINGUAS="${mylinguas}"
132 dodoc ANNOUNCE ChangeLog NEWS README RELEASE-NOTES UPGRADING
134 if use linguas_he ; then
135 insinto /usr/share/lyx/bind
136 doins "${DISTDIR}"/hebrew.bind
137 dodoc "${DISTDIR}"/preferences
140 domenu "${FILESDIR}"/lyx.desktop
142 cd "${WORKDIR}"/${FONT_P}
143 emake DESTDIR="${D}" install || die "Font installation failed"
145 font_src_install
147 if use latex ; then
148 dosym ../../../lyx/tex /usr/share/texmf/tex/latex/lyx
152 pkg_postinst() {
153 font_pkg_postinst
155 if use latex ; then
156 texhash
159 if use linguas_he ; then
160 elog
161 elog "How to use Hebrew in LyX:"
162 elog "bunzip2 /usr/share/doc/${PF}/preferences.bz2 into ~/.lyx/preferences"
163 elog "or, read http://cs.haifa.ac.il/~dekelts/lyx/instructions2.html"
164 elog "for instructions on using lyx's own preferences dialog to equal effect."
165 elog
168 elog
169 elog "There are known issues in the case of 1.4->1.5 config files transition."
170 elog "In case your File->Export list is incomplete try reconfiguring or even"
171 elog "remove the old configuration files in ~/.lyx ."
172 elog
175 pkg_postrm() {
176 if use latex ; then
177 texhash