x11-libs/qt*: Moved qt-4.4.0_rc1 to new eclass.
[gentoo-soor-overlay.git] / x11-libs / qt-xmlpatterns / qt-xmlpatterns-4.4.0_rc1.ebuild
blob951a1586402a85647061a7f652e5abf707ff0729
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="1"
6 inherit qt4-qt-copy
8 DESCRIPTION="The patternist module for the Qt toolkit."
9 HOMEPAGE="http://www.trolltech.com/"
11 LICENSE="|| ( QPL-1.0 GPL-3 GPL-2 )"
12 SLOT="4"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
16 DEPEND="~x11-libs/qt-core-${PV}"
17 RDEPEND="${DEPEND}"
19 QT4_TARGET_DIRECTORIES="src/xmlpatterns tools/xmlpatterns"
20 QCONFIG_ADD="xmlpatterns"
21 QCONFIG_DEFINE="QT_XMLPATTERNS"
23 src_compile() {
24 local myconf
25 myconf="${myconf} -xmlpatterns"
27 qt4-build_src_compile