x11-libs/qt*: Moved qt-4.4.0_rc1 to new eclass.
[gentoo-soor-overlay.git] / x11-libs / qt-svg / qt-svg-4.4.0_rc1.ebuild
blobf374d4de5b7b2712d02da26d6410d9b8612968d3
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit qt4-qt-copy
7 DESCRIPTION="The SVG module for the Qt toolkit."
8 HOMEPAGE="http://www.trolltech.com/"
10 LICENSE="|| ( QPL-1.0 GPL-3 GPL-2 )"
11 SLOT="4"
12 KEYWORDS="~amd64 ~x86"
13 IUSE=""
15 DEPEND="~x11-libs/qt-gui-${PV}"
16 RDEPEND="${DEPEND}"
18 QCONFIG_ADD="svg"
19 QCONFIG_DEFINE="QT_SVG"
20 QT4_TARGET_DIRECTORIES="
21 src/svg
22 src/plugins/imageformats/svg
23 src/plugins/iconengines/svgiconengine"
25 src_compile() {
26 local myconf
27 myconf="${myconf} -svg -no-xkb -no-tablet -no-fontconfig -no-xrender -no-xrandr
28 -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
29 -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
30 -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
31 -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
32 -no-fontconfig -no-glib -no-opengl"
34 qt4-build_src_compile