x11-libs/qt: more EAPI="1" forgettingsingsings.
[gentoo-soor-overlay.git] / x11-libs / qt-test / qt-test-4.4.0_rc1.ebuild
blob773767a1302b33afb71ad7eaa2b298424ab086d4
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="1"
6 inherit qt4-qt-copy
8 DESCRIPTION="The testing framework module for the Qt toolkit."
9 HOMEPAGE="http://www.trolltech.com/"
11 LICENSE="|| ( QPL-1.0 GPL-3 GPL-2 )"
12 SLOT="4"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
16 DEPEND="~x11-libs/qt-core-${PV}"
17 RDEPEND="${DEPEND}"
19 QT4_TARGET_DIRECTORIES="src/testlib"
21 src_compile() {
22 local myconf
23 myconf="${myconf} -no-xkb -no-tablet -no-fontconfig -no-xrender -no-xrandr
24 -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
25 -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
26 -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
27 -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
28 -no-fontconfig -no-glib -no-opengl -no-svg"
30 qt4-build_src_compile