x11-libs/qt: more EAPI="1" forgettingsingsings.
[gentoo-soor-overlay.git] / x11-libs / qt-assistant / qt-assistant-4.4.0_rc1.ebuild
blob07385eba709ae87d2b8a3fdb2eec5d51e31d81ee
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="1"
6 inherit qt4-qt-copy
8 DESCRIPTION="The assistant help module for the Qt toolkit."
9 HOMEPAGE="http://www.trolltech.com/"
11 LICENSE="|| ( QPL-1.0 GPL-3 GPL-2 )"
12 SLOT="4"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="doc"
16 DEPEND="~x11-libs/qt-gui-${PV}
17 ~x11-libs/qt-sql-${PV}"
18 RDEPEND="${DEPEND}"
20 # Pixeltool isn't really assistant related, but it relies on
21 # the assistant libraries.
22 QT4_TARGET_DIRECTORIES="tools/assistant tools/pixeltool"
23 QT4_EXTRACT_DIRECTORIES="
24 src/3rdparty/clucene/
25 tools/shared/fontpanel"
27 pkg_setup() {
28 qt4-build_pkg_setup
30 if ! built_with_use x11-libs/qt-sql sqlite; then
31 die "You must first emerge x11-libs/qt-sql with the \"sqlite\" use flag in order to use qt-assistant"
35 src_compile() {
36 local myconf
38 myconf="${myconf} -no-xkb -no-tablet -no-fontconfig -no-xrender -no-xrandr
39 -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
40 -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
41 -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
42 -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility -no-fontconfig
43 -no-glib -no-opengl -no-qt3support -no-svg"
45 qt4-build_src_compile
48 src_install() {
49 qt4-build_src_install
50 domenu "${FILESDIR}"/assistant.desktop
51 use doc && dohtml -r doc/html/*