net-www/mozplugger: add opera to browser dep block.
[gentoo-soor-overlay.git] / net-www / mozplugger / mozplugger-1.10.2.ebuild
blobe1f1293ae690784fcf801e95d392855f207cdf21
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit nsplugins
7 DESCRIPTION="Streaming media plugin for Mozilla, based on netscape-plugger"
8 SRC_URI="http://mozplugger.mozdev.org/files/${P}.tar.gz"
9 HOMEPAGE="http://mozplugger.mozdev.org/"
11 KEYWORDS="~x86 ~ppc ~sparc ~amd64 ~alpha"
12 LICENSE="GPL-2"
14 SLOT="0"
15 IUSE=""
17 DEPEND="x11-libs/libX11"
18 RDEPEND="${DEPEND}
19 || (
20 net-libs/xulrunner
21 www-client/mozilla-firefox
22 www-client/seamonkey
23 www-client/opera
26 src_compile() {
27 cd "${S}"
28 emake linux || die
31 src_install() {
32 emake root="${D}" install
33 src_mv_plugins /usr/lib/mozilla/plugins
35 dodoc ChangeLog COPYING README