Add 4.4.0_rc1
[gentoo-soor-overlay.git] / x11-libs / qt-script / qt-script-4.4.0_rc1.ebuild
blobe3ebf3e40d5c574d7c29aa40496140b1271e64e8
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit qt4-build
7 DESCRIPTION="The ECMAScript module for the Qt toolkit"
8 HOMEPAGE="http://www.trolltech.com/"
10 LICENSE="|| ( QPL-1.0 GPL-3 GPL-2 )"
11 SLOT="4"
12 KEYWORDS="~amd64 ~x86"
13 IUSE=""
15 DEPEND="~x11-libs/qt-core-${PV}"
16 RDEPEND="${DEPEND}"
18 QT4_TARGET_DIRECTORIES="src/script/"
19 QT4_EXTRACT_DIRECTORIES="
20 include/Qt/
21 include/QtCore/
22 include/QtScript/
23 src/corelib/global/
24 src/corelib/kernel/
25 src/corelib/plugin/"
27 src_compile() {
28 local myconf
29 myconf="${myconf} -no-xkb -no-tablet -no-fontconfig -no-xrender -no-xrandr
30 -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
31 -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
32 -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
33 -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
34 -no-fontconfig -no-glib -no-opengl -no-svg"
36 qt4-build_src_compile