new-news/liferea: typo, in triplicate.
[gentoo-soor-overlay.git] / x11-libs / qt-dbus / qt-dbus-4.4.0_rc1.ebuild
blobbea72f65fb6633259b9a4dd3dff44dc6a05fda3a
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="1"
6 inherit qt4-qt-copy
8 DESCRIPTION="The DBus module for the Qt toolkit."
9 HOMEPAGE="http://www.trolltech.com/"
11 LICENSE="|| ( QPL-1.0 GPL-3 GPL-2 )"
12 SLOT="4"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
16 # depend on gui instead of core. There's a GUI based viewer that's built, and since it's a desktop
17 # protocol I don't know if there's value trying to derive it out into a core build
18 # The library itself, however, only depends on core and xml
19 DEPEND="~x11-libs/qt-core-${PV}
20 >=sys-apps/dbus-1.0.2"
21 RDEPEND="${DEPEND}"
23 QT4_TARGET_DIRECTORIES="
24 src/dbus
25 tools/qdbus/qdbus
26 tools/qdbus/qdbusxml2cpp
27 tools/qdbus/qdbuscpp2xml"
28 QCONFIG_ADD="dbus dbus-linked"
29 QCONFIG_DEFINE="QT_DBUS"
31 #FIXME: Check if these are still needed with the header package
32 QT4_EXTRACT_DIRECTORIES="
33 include/Qt/
34 include/QtCore/
35 include/QtDBus/
36 src/corelib/global/
37 src/corelib/io/
38 src/corelib/kernel/
39 src/corelib/thread/
40 src/corelib/tools/
43 src_compile() {
44 local myconf
45 myconf="${myconf} -dbus-linked"
47 qt4-build_src_compile