Add STGit.
[gentoo-soor-overlay.git] / dev-util / stgit / stgit-0.14.2.ebuild
bloba5bec3fe90b402d39e1853ec93acf486a3219791
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit distutils bash-completion
7 RESTRICT="primaryuri"
9 DESCRIPTION="Manage a stack of patches using GIT as a backend"
10 HOMEPAGE="http://www.procode.org/stgit/"
11 SRC_URI="http://homepage.ntlworld.com/cmarinas/${PN}/${P}.tar.gz"
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
16 IUSE=""
18 DEPEND=""
19 RDEPEND=">=dev-util/git-1.5"
21 src_install() {
22 sed -i -e 's-\(prefix:\) ~-\1 /usr-' setup.cfg
23 distutils_src_install
24 dodir /usr/share/doc/${PF}
25 mv "${D}/usr/share/${PN}/examples" "${D}/usr/share/doc/${PF}"
26 rmdir "${D}/usr/share/doc/${PN}"
27 dobashcompletion contrib/stgit-completion.bash ${PN}