qtads: version bump to 2.0.1
[gentoo-interactive-fiction.git] / games-engines / qtads / qtads-2.0.1.ebuild
blob2b0c1c9a6e7c159c67eb825d746e13ef2cee3af6
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="3"
7 inherit games qt4-r2
9 DESCRIPTION="Multimedia interpreter for TADS text adventures"
10 HOMEPAGE="http://qtads.sourceforge.net"
11 SRC_URI="mirror://sourceforge/qtads/${P}.tar.bz2"
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
18 # Note that for sdl-sound, we need the "mp3", not the "mpeg" USE flag. "mpeg"
19 # uses the SMPEG lib for decoding, which plays some MP3s at double speed. "mp3"
20 # uses SDL_sound's internal MPGLIB, which doesn't have that problem. It's OK
21 # if both "mp3" as well as "mpeg" are enabled, because SDL_sound tries MPGLIB
22 # first, and only if that fails will it use SMPEG.
23 DEPEND="x11-libs/qt-gui:4
24 media-libs/libsdl[audio]
25 media-libs/sdl-mixer[midi,vorbis]
26 media-libs/sdl-sound[mp3]"
27 RDEPEND="${DEPEND}"
29 DOCS="AUTHORS BUGS NEWS HTML_TADS_LICENSE README"
31 src_install() {
32 dogamesbin qtads || die
33 doman qtads.6 || die
34 dodoc ${DOCS} || die
35 make_desktop_entry qtads QTads
36 prepgamesdirs