Add QTads live ebuild
[gentoo-interactive-fiction.git] / dev-games / cheapglk / cheapglk-0.9.1.ebuild
blobd70e966834246b6cef29695cb7bfdf6e549598d9
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit eutils autotools
7 MY_P=${P//./}
8 DESCRIPTION="A stdio implementation of the Glk API"
9 HOMEPAGE="http://www.eblong.com/zarf/glk/"
10 SRC_URI="mirror://ifarchive/programming/glk/implementations/${MY_P}.tar.gz"
12 LICENSE="Zarf"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
17 DEPEND=">=dev-games/glk-headers-0.7.0-r1"
18 RDEPEND=""
20 S=${WORKDIR}/${PN}
22 src_unpack() {
23 unpack ${A}
24 cd "${S}"
26 epatch "${FILESDIR}"/cheapglk-0.9.0-r1-garglk-extensions.patch
28 cp "${FILESDIR}"/cheapglk-0.9.0-configure.ac configure.ac || die "cp configure.ac failed"
29 cp "${FILESDIR}"/cheapglk-0.9.0-Makefile.am Makefile.am || die "cp Makefile.am failed"
30 sed -i -e "s,@PV@,${PV}," configure.ac || die "sed failed"
31 eautoreconf
33 rm glk.h gi_blorb.h gi_dispa.h glkstart.h || die "rm glk headers failed"
36 src_install() {
37 emake DESTDIR="${D}" install || die "emake install failed"
38 dodoc notes.txt || die "dodoc failed"
40 insinto /etc/glkloader.d
41 cat >"${T}"/cheapglk.rc <<-EOF
42 [Cheap]
43 path = /usr/$(get_libdir)/libcheapglk.so
44 EOF
45 doins "${T}"/cheapglk.rc || die "doins cheapglk.rc failed"