grotesque: use relative icon filename, add GenericName to desktop file
[gentoo-interactive-fiction.git] / games-util / grotesque / grotesque-0.9.2-r1.ebuild
blobc3f187887ae663507aa704029e6d31e04cd17fd4
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="3"
6 PYTHON_DEPEND="2:2.7"
8 inherit eutils distutils
10 DESCRIPTION="Interactive Fiction library manager"
11 HOMEPAGE="http://grotesque.sourceforge.net"
12 SRC_URI="mirror://sourceforge/grotesque/${P}-gtk2.tar.gz"
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS="amd64 x86"
17 IUSE=""
19 DEPEND="dev-python/pygtk"
20 RDEPEND="${DEPEND}"
22 src_install() {
23 distutils_src_install --install-data="/usr/share/doc/${PF}"
24 rm "${D}/usr/share/doc/${PF}/COPYING"
25 doicon src/grotesque/data/grotesque_icon.png
26 make_desktop_entry grotesque Grotesque grotesque_icon Game "GenericName=IF Library Manager"