Delete games-engines/qtads-1.9
[gentoo-interactive-fiction.git] / dev-games / cheapglk / cheapglk-0.9.0.ebuild
blobb82238331315d32995098a96137ceec9eba92d6a
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit eutils autotools
7 MY_P=${P//./}
8 DESCRIPTION="A stdio implementation of the Glk API"
9 HOMEPAGE="http://www.eblong.com/zarf/glk/"
10 SRC_URI="mirror://ifarchive/programming/glk/implementations/${MY_P}.tar.gz"
12 LICENSE="Zarf"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
17 DEPEND="dev-games/glk-headers"
18 RDEPEND=""
20 S=${WORKDIR}/${PN}
22 src_unpack() {
23 unpack ${A}
24 cd "${S}"
26 epatch "${FILESDIR}"/cheapglk-0.9.0-commandline.patch
27 epatch "${FILESDIR}"/cheapglk-0.9.0-garglk-extensions.patch
29 cp "${FILESDIR}"/cheapglk-0.9.0-configure.ac configure.ac || die "cp configure.ac failed"
30 cp "${FILESDIR}"/cheapglk-0.9.0-Makefile.am Makefile.am || die "cp Makefile.am failed"
31 sed -i -e "s,@PV@,${PV}," configure.ac || die "sed failed"
32 eautoreconf
34 rm glk.h gi_blorb.h gi_dispa.h glkstart.h || die "rm glk headers failed"
37 src_install() {
38 emake DESTDIR="${D}" install || die "emake install failed"
39 dodoc notes.txt || die "dodoc failed"
41 insinto /etc/glkloader.d
42 cat >"${T}"/cheapglk.rc <<-EOF
43 [Cheap]
44 path = /usr/$(get_libdir)/libcheapglk.so
45 EOF
46 doins "${T}"/cheapglk.rc || die "doins cheapglk.rc failed"