grotesque: Convert Python shebangs, use games.eclass, revbump
[gentoo-interactive-fiction.git] / dev-games / gnome-inform7 / gnome-inform7-7.5u_p92_p1.ebuild
blob2eb930b4b12de27b6e6e9d86a20595e2780d94d8
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI=1
7 inherit eutils versionator autotools gnome2-utils
9 MY_MAJOR=$(get_version_component_range 2)
10 MY_LETTER=$(get_version_component_range 3)
11 MY_MINOR=$(get_version_component_range 4)
12 MY_PATCH=$(get_version_component_range 5)
14 MY_LOWERS=abcdefghijklmnopqrstuvwxyz
15 MY_UPPERS=ABCDEFGHIJKLMNOPQRSTUVWXYZ
16 MY_INDEX=${MY_LOWERS%${MY_LETTER}*}
17 MY_UPPER=${MY_UPPERS:${#MY_INDEX}:1}
19 MY_PV=${MY_MAJOR}${MY_UPPER}${MY_MINOR#p}${MY_PATCH:+.${MY_PATCH#p}}
20 DESCRIPTION="GNOME user interface for Inform 7"
21 HOMEPAGE="http://inform7.com/ http://sourceforge.net/projects/gnome-inform7/"
22 SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}.tar.gz"
24 LICENSE="GPL-2 LICENSE-BITSTREAM font-bh-ttf"
25 SLOT="0"
26 KEYWORDS="~amd64 ~x86"
27 IUSE="linguas_es" # optional nls seems broken
29 RESTRICT="test" # intltool silliness
31 DEPEND="=app-text/gtkspell-2*
32 dev-libs/dbus-glib
33 >=gnome-base/libgnomeui-2
34 gnome-extra/gtkhtml:3.14
35 media-libs/freetype:2
36 media-libs/jpeg
37 media-libs/libpng
38 media-libs/libsdl
39 media-libs/sdl-mixer
40 media-libs/sdl-sound
41 || ( >=sys-apps/util-linux-2.16
42 <sys-libs/e2fsprogs-libs-1.41.8
43 <sys-fs/e2fsprogs-1.41.0 )
44 virtual/libintl
45 >=x11-libs/gtk+-2.8:2
46 x11-libs/gtksourceview:2.0"
47 RDEPEND="${DEPEND}
48 ~dev-lang/inform-${PV%${MY_PATCH:+_${MY_PATCH}}}
49 games-engines/glkfrotz
50 games-engines/glulxe"
51 DEPEND="${DEPEND}
52 dev-games/glk-headers
53 >=dev-util/intltool-0.35.0
54 dev-util/pkgconfig
55 sys-devel/gettext"
57 S=${WORKDIR}/${PN}-${MY_PV}
59 src_unpack() {
60 unpack ${A}
61 cd "${S}"
63 epatch "${FILESDIR}"/gnome-inform7-5U92.1-unbundling.patch
64 epatch "${FILESDIR}"/gnome-inform7-5J39-no-ossp-uuid.patch
66 eautoreconf
68 rm src/gtkterp/garglk/{glk,gi_blorb,gi_dispa,glkstart}.h || die "rm glk headers failed"
71 src_compile() {
72 # Don't build libgtkerp-garglk.a: the library is useless except
73 # when running under the IDE, and the IDE uses the glkfrotz and
74 # glulxe binaries linked against glkloader.
75 econf --disable-static || die "econf failed"
76 emake || die "emake failed"
79 src_install() {
80 emake DESTDIR="${D}" GCONFTOOL=true install || die "emake install failed"
81 dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die "dodoc failed"
82 dodoc src/gtkterp/{CharterBT.txt,TODO-garglk} || die "dodoc gtkterp failed"
84 cd "${D}"/usr/share
85 mv gnome-inform7/Documentation doc/${PF}/html || die "mv Documentation failed"
86 dosym /usr/share/doc/${PF}/html /usr/share/gnome-inform7/Documentation || die "dosym Documentation failed"
88 dosym /usr/{libexec,share/gnome-inform7/Compilers}/cBlorb || die "dosym cBlorb failed"
89 dosym /usr/{libexec,share/gnome-inform7/Compilers}/inform-6.31-biplatform || die "dosym inform-6.31-biplatform failed"
90 dosym /usr/{libexec,share/gnome-inform7/Compilers}/ni || die "dosym ni failed"
92 dosym /usr/share/{,gnome-}inform7/Inform7 || die "dosym Inform7 failed"
93 dosym /usr/share/{,gnome-}inform7/Library || die "dosym Library failed"
96 pkg_preinst() {
97 gnome2_gconf_savelist
100 pkg_postinst() {
101 gnome2_gconf_install
104 #pkg_prerm() {
105 # gnome2_gconf_uninstall