games-engines/hugor: Add media-sound/fluidsynth slot op
[gentoo-interactive-fiction.git] / dev-python / pyifbabel / pyifbabel-0.4.ebuild
blob03470d71ddee0f515312ba78e2c399c8504072ea
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="6"
6 PYTHON_COMPAT=( python2_7 )
8 inherit distutils-r1
10 DESCRIPTION="Pure-Python implementation of the Treaty of Babel"
11 HOMEPAGE="http://pyifbabel.invergo.net/"
12 SRC_URI="http://pyifbabel.invergo.net/download/${P}.tar.gz"
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS="amd64 x86"
17 IUSE=""
19 DEPEND="!<games-util/grotesque-0.9.5.1"
20 RDEPEND="${DEPEND}"
22 PATCHES=( "${FILESDIR}"/pyifbabel-0.4-get_resources.patch )
24 python_prepare() {
25 python_fix_shebang .
26 sed -i -e "s,doc_dir = .*,doc_dir = '/usr/share/doc/${PF}'," setup.py || die "sed failed"
29 python_install_all() {
30 distutils-r1_python_install_all
31 rm "${D}/usr/share/doc/${PF}/COPYING" || die "rm COPYING failed"