eapi=4
[gentoo-china-overlay.git] / app-i18n / fcitx / fcitx-9999.ebuild
blobdc11c0569e869bd2a592e9376f9e7142a3b83fea
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="4"
7 EHG_REVISION="default"
8 EHG_REPO_URI="https://fcitx.googlecode.com/hg"
9 inherit autotools mercurial
11 DESCRIPTION="Free Chinese Input Toy for X. Another Chinese XIM Input Method"
12 HOMEPAGE="http://fcitx.googlecode.com"
13 SRC_URI="${HOMEPAGE}/files/pinyin.tar.gz ${HOMEPAGE}/files/table.tar.gz"
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS=""
18 IUSE="dbus debug +pango"
19 RESTRICT="mirror"
21 RDEPEND="media-libs/fontconfig
22 x11-libs/cairo[X]
23 x11-libs/libX11
24 x11-libs/libXrender
25 dbus? ( sys-apps/dbus )
26 pango? ( x11-libs/pango )"
27 DEPEND="${RDEPEND}
28 dev-util/intltool
29 dev-util/pkgconfig
30 sys-devel/gettext
31 x11-proto/xproto"
33 src_prepare() {
34 cp -v "${DISTDIR}"/pinyin.tar.gz "${S}"/data && \
35 cp -v "${DISTDIR}"/table.tar.gz "${S}"/data/table || \
36 die "failed to copy code tables"
38 epatch "${FILESDIR}"/${PN}-remove-md5checks.patch
39 intltoolize -c -f || die "failed to run intltoolize"
40 eautoreconf
43 src_configure() {
44 econf --enable-tray \
45 --enable-recording \
46 $(use_enable dbus) \
47 $(use_enable debug) \
48 $(use_enable pango)