src/rotate.[ch]: Converted plain comments into doxygen comments.
[geda-pcb/pcjc2.git] / debian / rules
blob930c2ccb2abeb2a5802cc8de5ad3c32bcc43b6aa
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # debian/rules file for the Debian/GNU Linux pcb package
4 # Copyright 1997-99 by Hartmut Koptein <koptein@debian.org>
5 package = pcb
6 CONFIGURE_OPTS=--enable-dbus --disable-update-desktop-database --disable-update-mime-database --enable-coord64 LDFLAGS="$(LDFLAGS) -Wl,--as-needed"
7 export DH_OPTIONS=-v
8 export DH_VERBOSE=1
11 dh $@
13 override_dh_auto_configure:
14 ./autogen.sh
15 dh_auto_configure --builddirectory=build_gtk -- $(CONFIGURE_OPTS) \
16 --with-gui=gtk
17 dh_auto_configure --builddirectory=build_lesstif -- $(CONFIGURE_OPTS) \
18 --with-gui=lesstif --disable-doc
20 override_dh_auto_build:
21 dh_auto_build -S autoconf --builddirectory=build_gtk
22 dh_auto_build -S autoconf --builddirectory=build_lesstif
24 override_dh_auto_test:
25 #dh_auto_test --builddirectory build_gtk
26 #dh_auto_test --builddirectory build_lesstif
28 override_dh_auto_install:
29 dh_auto_install --builddirectory=build_gtk
31 override_dh_auto_clean:
32 dh_auto_clean --builddirectory=build_gtk
33 dh_auto_clean --builddirectory=build_lesstif
35 override_dh_install:
36 # Remove needlessly installed static library and header file before
37 # installing common files:
38 rm -rf $(CURDIR)/debian/tmp/usr/lib
39 rm -rf $(CURDIR)/debian/tmp/usr/include
40 dh_install -Xusr/bin -Xusr/share/doc -Xexamples -Xtutorial -Xusr/share/info
42 # Install pcb-gtk binary:
43 install build_gtk/src/pcb debian/$(package)-gtk/usr/bin/pcb-gtk
45 # Install pcb-lesstif binary:
46 install build_lesstif/src/pcb debian/$(package)-lesstif/usr/bin/pcb-lesstif
48 # Set executable bit for pcb tools:
49 [ ! -d debian/$(package)-common ] || chmod a+x debian/$(package)-common/usr/share/pcb/tools/MergePCBPS
50 [ ! -d debian/$(package)-common ] || chmod a+x debian/$(package)-common/usr/share/pcb/tools/Merge_dimPCBPS
51 [ ! -d debian/$(package)-common ] || chmod a+x debian/$(package)-common/usr/share/pcb/tools/tgo2pcb.tcl
52 [ ! -d debian/$(package)-common ] || chmod a+x debian/$(package)-common/usr/share/pcb/tools/PCB2HPGL
54 # Remove empty dirs:
55 [ ! -d debian/$(package)-common ] || find debian/$(package)-common -type d -empty -delete
57 override_dh_fixperms:
58 dh_fixperms
59 # Fix permissions of a couple of example files:
60 [ ! -d debian/$(package)-common ] || chmod -x debian/$(package)-common/usr/share/doc/$(package)-common/examples/LED.pcb
61 [ ! -d debian/$(package)-common ] || chmod -x debian/$(package)-common/usr/share/doc/$(package)-common/examples/LED.net
63 override_dh_installexamples:
64 dh_installexamples -XMakefile
66 override_dh_installchangelogs:
67 dh_installchangelogs -p$(package)-common
69 override_dh_installdocs:
70 # Only install docs in $(package)-common & link other packages' docs to
71 # $(package)-common:
72 dh_installdocs --link-doc=$(package)-common
74 override_dh_compress:
75 # exclude example files from compression
76 dh_compress -X.pcb -XLED