Imported gammu 0.90.7
[gammu.git] / gammu.spec
blobdc8f04a3f6491da1e93b25c67ce096edadcdb5f4
1 %define ver 0.90.7
2 %define name gammu
3 %define bluetooth 1
4 %define relnum 1
6 %if %_vendor == "suse"
7 %define rel %{relnum}suse
8 %else
9 %if %_vendor == "redhat"
10 %define rel %{relnum}rh
11 %else
12 %define rel %{relnum}
13 %endif
14 %endif
16 %if %bluetooth
17 %define configureparams ""
18 %else
19 %define configureparams "--disable-bluefbus --disable-blueobex --disable-bluephonet --disable-blueat"
20 %endif
22 Summary: Mobile phones tools for Unix (Linux) and Win32
23 Name: %name
24 Version: %ver
25 Release: %rel
26 License: GPL
27 %if %_vendor == "suse"
28 Group: Hardware/Mobile
29 %else
30 Group: Applications/Communications
31 %endif
32 %if %bluetooth
33 %if %_vendor == "suse"
34 BuildRequires: bluez-libs >= 2.0
35 %else
36 BuildRequires: bluez-libs >= 2.0 bluez-libs-devel >= 2.0
37 %endif
38 %endif
39 Vendor: Marcin Wiacek <marcin@mwiacek.com>
40 Source: http://www.mwiacek.com/zips/gsm/%name/older/%{name}-%{ver}.tar.gz
41 URL: http://www.mwiacek.com/gsm/gammu/gammu.html
42 Buildroot: %{_tmppath}/%name-%version-root
44 %description
45 Gammu can do such things with cellular phones as making data calls,
46 updating the address book, changing calendar and ToDo entries, sending and
47 receiving SMS messages, loading and getting ring tones and pictures (different
48 types of logos), synchronizing time, enabling NetMonitor, managing WAP
49 settings and bookmarks and much more. Functions depend on the phone model.
51 %package devel
52 Summary: Development files for Gammu
53 %if %_vendor == "suse"
54 Group: Development/Libraries/C and C++
55 %else
56 Group: Development/Libraries
57 %endif
58 Autoreqprov: on
59 Requires: %name = %ver-%rel
61 %description devel
62 Gammu can do such things with cellular phones as making data calls,
63 updating the address book, changing calendar and ToDo entries, sending and
64 receiving SMS messages, loading and getting ring tones and pictures (different
65 types of logos), synchronizing time, enabling NetMonitor, managing WAP
66 settings and bookmarks and much more. Functions depend on the phone model.
68 %prep
69 %setup -q
71 %build
72 %if %_vendor == "redhat"
73 %configure --with-docdir=%_docdir/%name-%ver/ %configureparams
74 %else
75 %configure --with-docdir=%_docdir/%name/ %configureparams
76 %endif
77 make shared
79 %install
80 rm -rf %buildroot
81 make installshared DESTDIR=%buildroot
82 install -m 755 -d %buildroot%_docdir/gammu/other/config
83 install -m 755 -d %buildroot%_docdir/gammu/other/basic
84 install -m 755 -d %buildroot%_docdir/gammu/other/smsdutil
85 install -m 755 other/config/gammu-config %buildroot%_docdir/gammu/other/config
86 install -m 644 other/basic/* %buildroot%_docdir/gammu/other/basic
87 install -m 644 other/smsdutil/* %buildroot%_docdir/gammu/other/smsdutil
89 %post
90 if test -f /etc/ld.so.conf ; then
91 /sbin/ldconfig
94 %postun
95 if test -f /etc/ld.so.conf ; then
96 /sbin/ldconfig
99 %files
100 %defattr(-,root,root)
101 %_bindir/*
102 %_libdir/*.so*
103 #localisations:
104 /usr/share/gammu
105 %doc %_mandir/man1/*
106 %if %_vendor == "redhat"
107 %doc %_docdir/%name-%ver
108 %else
109 %doc %_docdir/%name
110 %endif
112 %files devel
113 %defattr(-,root,root)
114 %_includedir/%name
115 %_libdir/pkgconfig/%name.pc
116 %_libdir/*.a
118 %clean
119 rm -rf %buildroot
121 %changelog
122 * Wed Nov 12 2003 Michal Cihar <michal@cihar.com>
123 - distiguish between packaging on SUSE and Redhat
124 - build depends on bluez if wanted
126 * Mon Nov 10 2003 Peter Soos <sp@osb.hu>
127 - using rpm macros where is possible
128 - added ldconfig to post/postun
130 * Mon Nov 03 2003 Michal Cihar <michal@cihar.com>
131 - split devel package
133 * Thu Jan 02 2003 Michal Cihar <michal@cihar.com>
134 - made it install in directories that are defined in rpm
136 * Sun Nov 10 2002 Marcin Wiacek <marcin@mwiacek.com>
137 - topnet.pl email no more available
139 * Sun Sep 30 2002 Marcin Wiacek <marcin-wiacek@topnet.pl>
140 - build system is now really working OK
142 * Sat Sep 15 2002 R P Herrold <herrold@owlriver.com>
143 - initial packaging