fix XEP-202 implementation, child element must be <time>, not <query>. Fixes #5412
[gajim.git] / debian / rules
blobf5af9a300493fa81721e0660e54d7f141b63aafa
1 #!/usr/bin/make -f
2 DEB_PYTHON_SYSTEM=pysupport
4 # Debhelper must be included before python-distutils to use
5 # # # dh_python / dh_pycentral / dh_pysupport
6 include /usr/share/cdbs/1/rules/debhelper.mk
7 include /usr/share/cdbs/1/rules/simple-patchsys.mk
8 include /usr/share/cdbs/1/class/autotools.mk
10 PYTHONVER = 2.5
11 DEB_CONFIGURE_EXTRA_FLAGS := --prefix=/usr
12 DEB_MAKE_BUILD_TARGET := all PYTHON=python$(PYTHONVER)
13 DEB_MAKE_INSTALL_TARGET = install PYTHON=python$(PYTHONVER) DESTDIR=$(DEB_DESTDIR)
15 binary-install/gajim::
16 rm $(DEB_DESTDIR)/usr/share/gajim/src/common/GnuPGInterface.py*
17 dh_pysupport -pgajim
18 convert $(DEB_DESTDIR)/usr/share/pixmaps/gajim.png -resize 32x32 $(DEB_DESTDIR)/usr/share/pixmaps/gajim.xpm
19 install -m 0644 debian/gajim.lintian $(DEB_DESTDIR)/usr/share/lintian/overrides/gajim