Switch all URLs from ftp.gnu.org to ftpmirror.gnu.org, along with usng http instead...
[foam-extend-3.2.git] / ThirdParty / rpmBuild / SPECS / mpfr-3.0.0.spec
blobc7748461c9d9f9d142da36a391a312515cf29c01
1 #------------------------------------------------------------------------------
2 # ========= |
3 # \\ / F ield | foam-extend: Open Source CFD
4 # \\ / O peration |
5 # \\ / A nd | For copyright notice see file Copyright
6 # \\/ M anipulation |
7 #------------------------------------------------------------------------------
8 # License
9 # This file is part of foam-extend.
11 # foam-extend is free software: you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation, either version 3 of the License, or (at your
14 # option) any later version.
16 # foam-extend is distributed in the hope that it will be useful, but
17 # WITHOUT ANY WARRANTY; without even the implied warranty of
18 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
19 # General Public License for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with foam-extend. If not, see <http://www.gnu.org/licenses/>.
24 # Script
25 # RPM spec file for mpfr-3.0.0
27 # Description
28 # RPM spec file for creating a relocatable RPM
30 # Author:
31 # Martin Beaudoin, Hydro-Quebec, (2010)
33 #------------------------------------------------------------------------------
35 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
36 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
37 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
39 # Disable the generation of debuginfo packages
40 %define debug_package %{nil}
42 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
43 %define _topdir %{_WM_THIRD_PARTY_DIR}/rpmBuild
44 %define _tmppath %{_topdir}/tmp
46 # Will install the package directly $WM_THIRD_PARTY_DIR
47 # Some comments about package relocation:
48 # By using this prefix for the Prefix: parameter in this file, you will make this
49 # package relocatable.
51 # This is fine, as long as your software is itself relocatable.
53 # Simply take note that libraries built with libtool are not relocatable because the
54 # prefix we specify will be hard-coded in the library .la files.
55 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
57 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
58 # not be able to reutilize this RPM, even though it is relocatable. You will need to
59 # regenerate the RPM.
61 %define _prefix %{_WM_THIRD_PARTY_DIR}
63 %define name mpfr
64 %define release %{_WM_OPTIONS}
65 %define version 3.0.0
67 %define buildroot %{_topdir}/BUILD/%{name}-%{version}-root
69 BuildRoot: %{buildroot}
70 Summary: mpfr
71 License: Unkown
72 Name: %{name}
73 Version: %{version}
74 Release: %{release}
75 URL: http://ftpmirror.gnu.org/mpfr
76 Source: %url/%{name}-%{version}.tar.gz
77 Prefix: %{_prefix}
78 Group: Development/Tools
80 %define _installPrefix %{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
82 %description
83 %{summary}
85 %prep
86 %setup -q
88 %build
89 # export WM settings in a form that GNU configure recognizes
90 [ -n "$WM_CC" ] && export CC="$WM_CC"
91 [ -n "$WM_CXX" ] && export CXX="$WM_CXX"
92 [ -n "$WM_CFLAGS" ] && export CFLAGS="$WM_CFLAGS"
93 [ -n "$WM_CXXFLAGS" ] && export CXXFLAGS="$WM_CXXFLAGS"
94 [ -n "$WM_LDFLAGS" ] && export LDFLAGS="$WM_LDFLAGS"
96 GMP_VERSION=gmp-5.0.1
97 ./configure \
98 --prefix=%{_installPrefix} \
99 --with-gmp=$WM_THIRD_PARTY_DIR/packages/$GMP_VERSION/platforms/$WM_OPTIONS
101 [ -z "$WM_NCOMPPROCS" ] && WM_NCOMPPROCS=1
102 make -j $WM_NCOMPPROCS
104 %install
105 make install DESTDIR=$RPM_BUILD_ROOT
108 # Creation of foam-extend specific .csh and .sh files"
110 echo ""
111 echo "Generating foam-extend specific .csh and .sh files for the package %{name}-%{version}"
112 echo ""
114 # Generate package specific .sh file for foam-extend
116 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/etc
117 cat << DOT_SH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.sh
118 # Load %{name}-%{version} libraries and binaries if available
119 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
121 export MPFR_DIR=\$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
123 [ -d \$MPFR_DIR/lib ] && _foamAddLib \$MPFR_DIR/lib
125 # Enable access to the package applications if present
126 [ -d \$MPFR_DIR/bin ] && _foamAddPath \$MPFR_DIR/bin
127 DOT_SH_EOF
130 # Generate package specific .csh file for foam-extend
132 cat << DOT_CSH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.csh
133 # Load %{name}-%{version} libraries and binaries if available
134 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
135 setenv MPFR_DIR \$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
137 if ( -e \$MPFR_DIR/lib ) then
138 _foamAddLib \$MPFR_DIR/lib
139 endif
141 if ( -e \$MPFR_DIR/bin ) then
142 _foamAddPath \$MPFR_DIR/bin
143 endif
144 DOT_CSH_EOF
146 #finally, generate a .tgz file for systems where using rpm for installing packages
147 # as a non-root user might be a problem.
148 (mkdir -p %{_topdir}/TGZS/%{_target_cpu}; cd $RPM_BUILD_ROOT/%{_prefix}; tar -zcvf %{_topdir}/TGZS/%{_target_cpu}/%{name}-%{version}.tgz packages/%{name}-%{version})
151 %clean
152 rm -rf %{buildroot}
154 %files
155 %defattr(-,root,root)
156 %{_installPrefix}