Switch all URLs from ftp.gnu.org to ftpmirror.gnu.org, along with usng http instead...
[foam-extend-3.2.git] / ThirdParty / rpmBuild / SPECS / gcc-4.8.4.spec
blobc84d870eb56c486d1de8c811767ca0350765c1af
1 #------------------------------------------------------------------------------
2 # ========= |
3 # \\ / F ield | foam-extend: Open Source CFD
4 # \\ / O peration |
5 # \\ / A nd | For copyright notice see file Copyright
6 # \\/ M anipulation |
7 #------------------------------------------------------------------------------
8 # License
9 # This file is part of foam-extend.
11 # foam-extend is free software: you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation, either version 3 of the License, or (at your
14 # option) any later version.
16 # foam-extend is distributed in the hope that it will be useful, but
17 # WITHOUT ANY WARRANTY; without even the implied warranty of
18 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
19 # General Public License for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with foam-extend. If not, see <http://www.gnu.org/licenses/>.
24 # Script
25 # RPM spec file for gcc-4.8.4
27 # Description
28 # RPM spec file for creating a relocatable RPM
30 # Author:
31 # Martin Beaudoin, Hydro-Quebec, (2015)
33 #------------------------------------------------------------------------------
35 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
36 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
37 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
39 # Disable the generation of debuginfo packages
40 %define debug_package %{nil}
42 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
43 %define _topdir %{_WM_THIRD_PARTY_DIR}/rpmBuild
44 %define _tmppath %{_topdir}/tmp
46 # Will install the package directly $WM_THIRD_PARTY_DIR
47 # Some comments about package relocation:
48 # By using this prefix for the Prefix: parameter in thi file, you will make this
49 # package relocatable.
51 # This is fine, as long as your software is itself relocatable.
53 # Simply take note that libraries built with libtool are not relocatable because the
54 # prefix we specify will be hard-coded in the library .la files.
55 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
57 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
58 # not be able to reutilize this RPM, even though it is relocatable. You will need to
59 # regenerate the RPM.
61 %define _prefix %{_WM_THIRD_PARTY_DIR}
63 %define name gcc
64 %define release %{_WM_OPTIONS}
65 %define version 4.8.4
67 %define buildroot %{_topdir}/BUILD/%{name}-%{version}-root
69 BuildRoot: %{buildroot}
70 Summary: gcc
71 License: Unkown
72 Name: %{name}
73 Version: %{version}
74 Release: %{release}
75 URL: http://ftpmirror.gnu.org/gcc/gcc-4.8.4
76 Source: %url/%{name}-%{version}.tar.gz
77 Prefix: %{_prefix}
78 Group: Development/Tools
81 %define _installPrefix %{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
83 %description
84 %{summary}
86 %prep
87 %setup -q
89 %build
90 # export WM settings in a form that GNU configure recognizes
91 [ -n "$WM_CC" ] && export CC="$WM_CC"
92 [ -n "$WM_CXX" ] && export CXX="$WM_CXX"
93 [ -n "$WM_CFLAGS" ] && export CFLAGS="$WM_CFLAGS"
94 [ -n "$WM_CXXFLAGS" ] && export CXXFLAGS="$WM_CXXFLAGS"
95 [ -n "$WM_LDFLAGS" ] && export LDFLAGS="$WM_LDFLAGS"
97 # Download prequisite libraries
98 ./contrib/download_prerequisites
100 # Fixing an old bug related to gmp and m4 and gcc
101 # See https://gmplib.org/list-archives/gmp-bugs/2008-August/001114.html
102 # This bug will occur when compiling gmp as an internal gcc package.
103 # This bug will occur on Centos 6.2. and probably on other OSes as well
104 cp gmp/configure.in gmp/configure.in.orig
105 cp gmp/configure gmp/configure.orig
106 sed "s/m4-not-needed/m4/g" gmp/configure.in > gmp/configure.in.patched
107 sed "s/m4-not-needed/m4/g" gmp/configure > gmp/configure.patched
108 mv gmp/configure.in.patched gmp/configure.in
109 mv gmp/configure.patched gmp/configure
111 # Create working directory
112 mkdir ./objBuildDir
113 cd ./objBuildDir
115 %ifos darwin
116 # Couple of fixes for OSX Yosemite and Xcode 6.3.1
117 # See here : http://lists.gnu.org/archive/html/libtool-patches/2014-09/msg00001.html
118 # and here : https://gcc.gnu.org/bugzilla/show_bug.cgi?id=63610
119 # for the details.
120 # Hopefully, this will all be resolved soon before MACOSX_DEPLOYMENT_TARGET=10.11...
121 if [ "$MACOSX_DEPLOYMENT_TARGET" = "10.10" ]
122 then
123 export MACOSX_DEPLOYMENT_TARGET="10.9"
126 # Another necessary fix:
127 # Use 'bootstrap-debug' build configuration to force stripping of object
128 # files prior to comparison during bootstrap (broken by Xcode 6.3).
129 # Fix taken from HomeBrew and MacPorts projects
131 ../configure \
132 --prefix=%{_installPrefix} \
133 --enable-languages=c,c++ \
134 --enable-shared \
135 --with-build-config=bootstrap-debug \
136 --disable-multilib
137 %else
138 ../configure \
139 --prefix=%{_installPrefix} \
140 --enable-languages=c,c++ \
141 --enable-shared \
142 --disable-multilib
143 %endif
145 [ -z "$WM_NCOMPPROCS" ] && WM_NCOMPPROCS=1
146 make -j $WM_NCOMPPROCS
148 %install
149 cd ./objBuildDir
150 make install DESTDIR=$RPM_BUILD_ROOT
152 # Creation of foam-extend specific .csh and .sh files"
154 echo ""
155 echo "Generating foam-extend specific .csh and .sh files for the package %{name}-%{version}"
156 echo ""
158 # Generate package specific .sh file for foam-extend
160 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/etc
161 cat << DOT_SH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.sh
162 # Load %{name}-%{version} libraries and binaries if available
163 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
165 export GCC_DIR=\$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
167 [ -d \$GCC_DIR/lib ] && _foamAddLib \$GCC_DIR/lib
169 [ -d \$GCC_DIR/lib64 ] && _foamAddLib \$GCC_DIR/lib64
171 # Enable access to the package applications if present
172 [ -d \$GCC_DIR/bin ] && _foamAddPath \$GCC_DIR/bin
173 DOT_SH_EOF
176 # Generate package specific .csh file for foam-extend
178 cat << DOT_CSH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.csh
179 # Load %{name}-%{version} libraries and binaries if available
180 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
181 setenv GCC_DIR \$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
183 if ( -e \$GCC_DIR/lib ) then
184 _foamAddLib \$GCC_DIR/lib
185 endif
187 if ( -e \$GCC_DIR/lib64 ) then
188 _foamAddLib \$GCC_DIR/lib64
189 endif
191 if ( -e \$GCC_DIR/bin ) then
192 _foamAddPath \$GCC_DIR/bin
193 endif
194 DOT_CSH_EOF
196 #finally, generate a .tgz file for systems where using rpm for installing packages
197 # as a non-root user might be a problem.
198 (mkdir -p %{_topdir}/TGZS/%{_target_cpu}; cd $RPM_BUILD_ROOT/%{_prefix}; tar -zcvf %{_topdir}/TGZS/%{_target_cpu}/%{name}-%{version}.tgz packages/%{name}-%{version})
201 %clean
202 rm -rf %{buildroot}
204 %files
205 %defattr(-,root,root)
206 %{_installPrefix}