Switch all URLs from ftp.gnu.org to ftpmirror.gnu.org, along with usng http instead...
[foam-extend-3.2.git] / ThirdParty / rpmBuild / SPECS / gcc-4.7.4.spec
blob9619e4ed7b27bf94967c39d08ad3e1307513d75f
1 #------------------------------------------------------------------------------
2 # ========= |
3 # \\ / F ield | foam-extend: Open Source CFD
4 # \\ / O peration |
5 # \\ / A nd | For copyright notice see file Copyright
6 # \\/ M anipulation |
7 #------------------------------------------------------------------------------
8 # License
9 # This file is part of foam-extend.
11 # foam-extend is free software: you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation, either version 3 of the License, or (at your
14 # option) any later version.
16 # foam-extend is distributed in the hope that it will be useful, but
17 # WITHOUT ANY WARRANTY; without even the implied warranty of
18 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
19 # General Public License for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with foam-extend. If not, see <http://www.gnu.org/licenses/>.
24 # Script
25 # RPM spec file for gcc-4.7.4
27 # Description
28 # RPM spec file for creating a relocatable RPM
30 # Author:
31 # Hrvoje Jasak, Wikki Ltd. (2015)
33 #------------------------------------------------------------------------------
35 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
36 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
37 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
39 # Disable the generation of debuginfo packages
40 %define debug_package %{nil}
42 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
43 %define _topdir %{_WM_THIRD_PARTY_DIR}/rpmBuild
44 %define _tmppath %{_topdir}/tmp
46 # Will install the package directly $WM_THIRD_PARTY_DIR
47 # Some comments about package relocation:
48 # By using this prefix for the Prefix: parameter in thi file, you will make this
49 # package relocatable.
51 # This is fine, as long as your software is itself relocatable.
53 # Simply take note that libraries built with libtool are not relocatable because the
54 # prefix we specify will be hard-coded in the library .la files.
55 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
57 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
58 # not be able to reutilize this RPM, even though it is relocatable. You will need to
59 # regenerate the RPM.
61 %define _prefix %{_WM_THIRD_PARTY_DIR}
63 %define name gcc
64 %define release %{_WM_OPTIONS}
65 %define version 4.7.4
67 %define buildroot %{_topdir}/BUILD/%{name}-%{version}-root
69 BuildRoot: %{buildroot}
70 Summary: gcc
71 License: Unkown
72 Name: %{name}
73 Version: %{version}
74 Release: %{release}
75 URL: http://ftpmirror.gnu.org/gcc/gcc-4.7.4
76 Source: %url/%{name}-%{version}.tar.gz
77 Prefix: %{_prefix}
78 Group: Development/Tools
81 %define _installPrefix %{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
83 %description
84 %{summary}
86 %prep
87 %setup -q
89 %build
90 # export WM settings in a form that GNU configure recognizes
91 [ -n "$WM_CC" ] && export CC="$WM_CC"
92 [ -n "$WM_CXX" ] && export CXX="$WM_CXX"
93 [ -n "$WM_CFLAGS" ] && export CFLAGS="$WM_CFLAGS"
94 [ -n "$WM_CXXFLAGS" ] && export CXXFLAGS="$WM_CXXFLAGS"
95 [ -n "$WM_LDFLAGS" ] && export LDFLAGS="$WM_LDFLAGS"
97 GMP_VERSION=gmp-5.1.2
98 MPFR_VERSION=mpfr-3.1.2
99 MPC_VERSION=mpc-1.0.1
101 mkdir ./objBuildDir
102 cd ./objBuildDir
104 ../configure \
105 --prefix=%{_installPrefix} \
106 --enable-languages=c,c++ \
107 --enable-shared \
108 --disable-multilib \
109 --with-mpc=$WM_THIRD_PARTY_DIR/packages/$MPC_VERSION/platforms/$WM_OPTIONS \
110 --with-gmp=$WM_THIRD_PARTY_DIR/packages/$GMP_VERSION/platforms/$WM_OPTIONS \
111 --with-mpfr=$WM_THIRD_PARTY_DIR/packages/$MPFR_VERSION/platforms/$WM_OPTIONS
113 [ -z "$WM_NCOMPPROCS" ] && WM_NCOMPPROCS=1
114 make -j $WM_NCOMPPROCS
116 %install
117 cd ./objBuildDir
118 make install DESTDIR=$RPM_BUILD_ROOT
120 # Creation of foam-extend specific .csh and .sh files"
122 echo ""
123 echo "Generating foam-extend specific .csh and .sh files for the package %{name}-%{version}"
124 echo ""
126 # Generate package specific .sh file for foam-extend
128 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/etc
129 cat << DOT_SH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.sh
130 # Load %{name}-%{version} libraries and binaries if available
131 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
133 export GCC_DIR=\$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
135 [ -d \$GCC_DIR/lib ] && _foamAddLib \$GCC_DIR/lib
137 [ -d \$GCC_DIR/lib64 ] && _foamAddLib \$GCC_DIR/lib64
139 # Enable access to the package applications if present
140 [ -d \$GCC_DIR/bin ] && _foamAddPath \$GCC_DIR/bin
141 DOT_SH_EOF
144 # Generate package specific .csh file for foam-extend
146 cat << DOT_CSH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.csh
147 # Load %{name}-%{version} libraries and binaries if available
148 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
149 setenv GCC_DIR \$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
151 if ( -e \$GCC_DIR/lib ) then
152 _foamAddLib \$GCC_DIR/lib
153 endif
155 if ( -e \$GCC_DIR/lib64 ) then
156 _foamAddLib \$GCC_DIR/lib64
157 endif
159 if ( -e \$GCC_DIR/bin ) then
160 _foamAddPath \$GCC_DIR/bin
161 endif
162 DOT_CSH_EOF
164 #finally, generate a .tgz file for systems where using rpm for installing packages
165 # as a non-root user might be a problem.
166 (mkdir -p %{_topdir}/TGZS/%{_target_cpu}; cd $RPM_BUILD_ROOT/%{_prefix}; tar -zcvf %{_topdir}/TGZS/%{_target_cpu}/%{name}-%{version}.tgz packages/%{name}-%{version})
169 %clean
170 rm -rf %{buildroot}
172 %files
173 %defattr(-,root,root)
174 %{_installPrefix}