1 #------------------------------------------------------------------------------
3 # \\ / F ield | OpenFOAM: The Open Source CFD Toolbox
5 # \\ / A nd | Copyright held by original author
7 #------------------------------------------------------------------------------
9 # This file is part of OpenFOAM.
11 # OpenFOAM is free software; you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation; either version 2 of the License, or (at your
14 # option) any later version.
16 # OpenFOAM is distributed in the hope that it will be useful, but WITHOUT
17 # ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
18 # FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
21 # You should have received a copy of the GNU General Public License
22 # along with OpenFOAM; if not, write to the Free Software Foundation,
23 # Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
26 # RPM spec file for scotch-5.1.10b
29 # RPM spec file for creating a relocatable RPM
32 # Martin Beaudoin, Hydro-Quebec, (2010)
34 #------------------------------------------------------------------------------
36 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
37 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
38 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
40 # Disable the generation of debuginfo packages
41 %define debug_package
%{nil}
43 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
44 %define _topdir
%{_WM_THIRD_PARTY_DIR}/rpmBuild
45 %define _tmppath
%{_topdir}/tmp
47 # Will install the package directly $WM_THIRD_PARTY_DIR
48 # Some comments about package relocation:
49 # By using this prefix for the Prefix: parameter in thi file, you will make this
50 # package relocatable.
52 # This is fine, as long as your software is itself relocatable.
54 # Simply take note that libraries built with libtool are not relocatable because the
55 # prefix we specify will be hard-coded in the library .la files.
56 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
58 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
59 # not be able to reutilize this RPM, even though it is relocatable. You will need to
62 %define _prefix
%{_WM_THIRD_PARTY_DIR}
65 %define release
%{_WM_OPTIONS}
66 %define version
5.1.10b
68 %define buildroot
%{_topdir}/BUILD/%{name}-%{version}-root
70 BuildRoot: %{buildroot}
76 URL: https
://gforge.inria.fr
/frs
/download.php
/27583
77 Source: %url/%{name}-%{version}.tar.gz
79 Group: Development
/Tools
80 Patch0: scotch
-5.1.10b_patch_0
82 %define _installPrefix
%{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
88 %setup -q
-n
%{name}_%{version}
93 # export WM settings in a form that GNU configure recognizes
94 [ -n "$WM_CC"
] && export CC
="$WM_CC"
95 [ -n "$WM_CXX"
] && export CXX
="$WM_CXX"
96 [ -n "$WM_CFLAGS"
] && export CFLAGS
="$WM_CFLAGS"
97 [ -n "$WM_CXXFLAGS"
] && export CXXFLAGS
="$WM_CXXFLAGS"
98 [ -n "$WM_LDFLAGS"
] && export LDFLAGS
="$WM_LDFLAGS"
101 # Here, unfortunately, some hand tweaking might be necessary if your system is not running Linux or MacOS X
103 ln
-s Make.inc
/Makefile.inc.i686_mac_darwin10.shlib Makefile.inc
105 ln
-s Make.inc
/Makefile.inc.i686_pc_linux2.shlib Makefile.inc
108 [ -z "$WM_NCOMPPROCS"
] && WM_NCOMPPROCS
=1
109 make -j $WM_NCOMPPROCS scotch CC
="$WM_CC" CXX
="$WM_CXX" CCD
="$WM_CC" CCS
="$WM_CC" AR
="$WM_CC"
110 make -j $WM_NCOMPPROCS ptscotch AR
="$WM_CC"
114 mkdir -p $RPM_BUILD_ROOT
%{_installPrefix}
115 make install prefix
=$RPM_BUILD_ROOT
%{_installPrefix}
117 # Creation of OpenFOAM specific .csh and .sh files"
120 echo "Generating OpenFOAM specific .csh and .sh files
for the package
%{name}-%{version}"
123 # Generate package specific .sh file for OpenFOAM
125 mkdir -p $RPM_BUILD_ROOT
/%{_installPrefix}/etc
126 cat
<< DOT_SH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.sh
127 # Load %{name}-%{version} libraries and binaries if available
128 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
130 export SCOTCH_DIR
=\$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/\$WM_OPTIONS
131 export SCOTCH_BIN_DIR
=\$SCOTCH_DIR
/bin
132 export SCOTCH_LIB_DIR
=\$SCOTCH_DIR
/lib
133 export SCOTCH_INCLUDE_DIR
=\$SCOTCH_DIR
/include
135 # Enable access to the runtime package applications and libraries
136 [ -d \$SCOTCH_BIN_DIR
] && _foamAddPath \$SCOTCH_BIN_DIR
137 [ -d \$SCOTCH_LIB_DIR
] && _foamAddLib \$SCOTCH_LIB_DIR
141 # Generate package specific .csh file for OpenFOAM
143 cat
<< DOT_CSH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.csh
144 # Load %{name}-%{version} libraries and binaries if available
145 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
146 setenv SCOTCH_DIR \$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/\$WM_OPTIONS
147 setenv SCOTCH_BIN_DIR \$SCOTCH_DIR
/bin
148 setenv SCOTCH_LIB_DIR \$SCOTCH_DIR
/lib
149 setenv SCOTCH_INCLUDE_DIR \$SCOTCH_DIR
/include
151 if ( -e \$SCOTCH_BIN_DIR
) then
152 _foamAddPath \$SCOTCH_BIN_DIR
155 if ( -e \$SCOTCH_LIB_DIR
) then
156 _foamAddLib \$SCOTCH_LIB_DIR
160 #finally, generate a .tgz file for systems where using rpm for installing packages
161 # as a non-root user might be a problem.
162 (mkdir -p
%{_topdir}/TGZS/%{_target_cpu}; cd $RPM_BUILD_ROOT/%{_prefix}; tar -zcvf %{_topdir}/TGZS/%{_target_cpu}/%{name}-%{version}.tgz packages/%{name}-%{version})
169 %defattr(-,root
,root
)