feature magic is an amplification factor for edge sharpening (not corners)
[engrid.git] / debian / rules
blobfa961271ab9f0b533b8e67a4ffd379c673ba565f
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
12 # Add here any variable or target overrides you need.
13 QMAKE=qmake-qt4 -recursive
14 CFLAGS=-O3
15 CXXFLAGS=-O3
16 DEB_BUILDDIR=src
17 DEB_QMAKE_CONFIG_VAL=debian
19 include /etc/lsb-release
21 ifeq "$(DISTRIB_RELEASE)" "10.10"
22 export VTKINCDIR=/usr/include/vtk-5.4/
23 export VTKLIBDIR=/usr/lib
24 endif
26 ifeq "$(DISTRIB_RELEASE)" "11.04"
27 export VTKINCDIR=/usr/include/vtk-5.4/
28 export VTKLIBDIR=/usr/lib
29 endif
31 ifeq "$(DISTRIB_RELEASE)" "11.10"
32 export VTKINCDIR=/usr/include/vtk-5.6/
33 export VTKLIBDIR=/usr/lib
34 endif
36 ifeq "$(DISTRIB_RELEASE)" "12.04"
37 export VTKINCDIR=/usr/include/vtk-5.8/
38 export VTKLIBDIR=/usr/lib
39 endif
41 ifeq "$(DISTRIB_RELEASE)" "12.10"
42 export VTKINCDIR=/usr/include/vtk-5.8/
43 export VTKLIBDIR=/usr/lib
44 endif
46 include /usr/share/cdbs/1/rules/debhelper.mk
47 include /usr/share/cdbs/1/class/qmake.mk