Use allocate/read for checksum calculation when reading small objects
[eblob.git] / debian / rules
blobeb6e2bc4b6447457f030936da57d00f674b6ebf8
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
13 # These are used for cross-compiling and for saving the configure script
14 # from having to guess our platform (since we know it already)
15 DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
16 DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
17 ifneq ($(DEB_HOST_GNU_TYPE),$(DEB_BUILD_GNU_TYPE))
18 CROSS= --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
19 else
20 CROSS= --build $(DEB_BUILD_GNU_TYPE)
21 endif
25 config.status:
26 dh_testdir
27 # Add here commands to configure the package.
28 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
29 cp -f /usr/share/misc/config.sub config.sub
30 endif
31 ifneq "$(wildcard /usr/share/misc/config.guess)" ""
32 cp -f /usr/share/misc/config.guess config.guess
33 endif
34 test -f ./configure || ./autogen.sh
35 ./configure $(CROSS) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info CFLAGS="$(CFLAGS)" LDFLAGS="-Wl,-z,defs"
38 build: build-stamp
40 build-stamp: config.status
41 dh_testdir
43 # Add here commands to compile the package.
44 $(MAKE)
45 #docbook-to-man debian/eblob.sgml > eblob.1
47 touch $@
49 clean:
50 dh_testdir
51 dh_testroot
52 rm -f build-stamp
54 # Add here commands to clean up after the build process.
55 [ ! -f Makefile ] || $(MAKE) distclean
56 rm -f config.sub config.guess
58 dh_clean
60 install: build
61 dh_testdir
62 dh_testroot
63 dh_prep
64 dh_installdirs
66 # Add here commands to install the package into debian/eblob.
67 $(MAKE) DESTDIR=$(CURDIR)/debian/eblob install
70 # Build architecture-independent files here.
71 binary-indep: install
72 # We have nothing to do by default.
74 # Build architecture-dependent files here.
75 binary-arch: install
76 dh_testdir
77 dh_testroot
78 dh_installchangelogs ChangeLog
79 dh_installdocs
80 dh_installexamples
81 # dh_install
82 # dh_installmenu
83 # dh_installdebconf
84 # dh_installlogrotate
85 # dh_installemacsen
86 # dh_installpam
87 # dh_installmime
88 # dh_python
89 # dh_installinit
90 # dh_installcron
91 # dh_installinfo
92 dh_installman
93 dh_link
94 dh_strip --dbg-package=eblob-dbg
95 # dh_compress
96 dh_fixperms
97 # dh_perl
98 dh_makeshlibs -V "eblob (>= $(shell head -n1 debian/changelog | sed -e 's/.*[(]//' | sed -e 's/[)].*//' | tr -d '\n' | cut -d . -f 1-2))"
99 dh_installdeb
100 dh_shlibdeps
101 dh_gencontrol
102 dh_md5sums
103 dh_builddeb
105 binary: binary-indep binary-arch
106 .PHONY: build clean binary-indep binary-arch binary install