3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
13 # These are used for cross-compiling and for saving the configure script
14 # from having to guess our platform (since we know it already)
15 DEB_HOST_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_HOST_GNU_TYPE
)
16 DEB_BUILD_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_BUILD_GNU_TYPE
)
17 ifneq ($(DEB_HOST_GNU_TYPE
),$(DEB_BUILD_GNU_TYPE
))
18 CROSS
= --build
$(DEB_BUILD_GNU_TYPE
) --host
$(DEB_HOST_GNU_TYPE
)
20 CROSS
= --build
$(DEB_BUILD_GNU_TYPE
)
27 # Add here commands to configure the package.
28 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
29 cp
-f
/usr
/share
/misc
/config.sub config.sub
31 ifneq "$(wildcard /usr/share/misc/config.guess)" ""
32 cp
-f
/usr
/share
/misc
/config.guess config.guess
34 test -f .
/configure || .
/autogen.sh
35 .
/configure
$(CROSS
) --prefix=/usr
--mandir=\
$${prefix}/share
/man
--infodir=\
$${prefix}/share
/info CFLAGS
="$(CFLAGS)" LDFLAGS
="-Wl,-z,defs"
40 build-stamp
: config.status
43 # Add here commands to compile the package.
45 #docbook-to-man debian/eblob.sgml > eblob.1
54 # Add here commands to clean up after the build process.
55 [ ! -f Makefile
] ||
$(MAKE
) distclean
56 rm -f config.sub config.guess
66 # Add here commands to install the package into debian/eblob.
67 $(MAKE
) DESTDIR
=$(CURDIR
)/debian
/eblob
install
70 # Build architecture-independent files here.
72 # We have nothing to do by default.
74 # Build architecture-dependent files here.
78 dh_installchangelogs ChangeLog
94 dh_strip
--dbg-package
=eblob-dbg
98 dh_makeshlibs
-V
"eblob (>= $(shell head -n1 debian/changelog | sed -e 's/.*[(]//' | sed -e 's/[)].*//' | tr -d '\n' | cut -d . -f 1-2))"
105 binary
: binary-indep binary-arch
106 .PHONY
: build
clean binary-indep binary-arch binary
install