Reduce differences with root_skels in contrib.
[dragonfly.git] / contrib / bsdinstaller-1.1.6 / ports / sysutils / libdfui / Makefile
blob6aa3193cce09dd4c2f8e43f7944f4827c6741546
1 # New ports collection makefile for: libdfui
2 # Date created: May 13, 2004
3 # Whom: Chris Pressey <cpressey@catseye.mine.nu>
5 PORTNAME= libdfui
6 PORTVERSION= 4.1
7 INTERNAL= YES
8 CATEGORIES= sysutils
9 DISTNAME= ${PORTNAME}-${PORTVERSION}
10 WRKSRC= work/${PORTNAME}
12 LIB_DEPENDS= aura.3:${PORTSDIR}/devel/libaura
14 MAINTAINER= cpressey@catseye.mine.nu
15 COMMENT= Abstract user interface protocol library
17 PLIST_FILES= lib/libdfui.a \
18 lib/libdfui.so \
19 lib/libdfui.so.4 \
20 include/dfui/dfui.h \
21 include/dfui/dump.h \
22 include/dfui/lang.h \
23 include/dfui/system.h
25 do-fetch:
26 @if [ ! -f ${_DISTDIR}${DISTNAME}${EXTRACT_SUFX} ]; then \
27 ${ECHO_MSG}; \
28 ${ECHO_MSG} "Distfile ${DISTNAME}${EXTRACT_SUFX} not found!"; \
29 ${ECHO_MSG}; \
30 ${ECHO_MSG} "This is an 'INTERNAL' port, meaning that the distfile is not retrieved"; \
31 ${ECHO_MSG} "from the Internet, but rather created from a local checkout of the"; \
32 ${ECHO_MSG} "BSD Installer CVS repository. Please see the shell scripts in the"; \
33 ${ECHO_MSG} "scripts/build directory of the repository for more information on how"; \
34 ${ECHO_MSG} "to create these distfiles."; \
35 false; \
38 do-install:
39 ${MKDIR} -p ${LOCALBASE}/include/dfui
40 ${INSTALL_DATA} -o root -g wheel -m 444 ${WRKSRC}/libdfui.a ${LOCALBASE}/lib/
41 ${INSTALL_DATA} -o root -g wheel -m 444 ${WRKSRC}/libdfui.so.4 ${LOCALBASE}/lib/
42 ${LN} -sf ${LOCALBASE}/lib/libdfui.so.4 ${LOCALBASE}/lib/libdfui.so
43 ${INSTALL_DATA} -o root -g wheel -m 444 ${WRKSRC}/dfui.h ${LOCALBASE}/include/dfui/
44 ${INSTALL_DATA} -o root -g wheel -m 444 ${WRKSRC}/dump.h ${LOCALBASE}/include/dfui/
45 ${INSTALL_DATA} -o root -g wheel -m 444 ${WRKSRC}/lang.h ${LOCALBASE}/include/dfui/
46 ${INSTALL_DATA} -o root -g wheel -m 444 ${WRKSRC}/system.h ${LOCALBASE}/include/dfui/
48 OSTYPE!=sysctl -n kern.ostype
50 .if ${OSTYPE} == "FreeBSD"
51 .include <bsd.port.mk>
52 .endif
54 .if ${OSTYPE} == "DragonFly"
55 .include <bsd.dfport.mk>
56 .endif