Reduce differences with root_skels in contrib.
[dragonfly.git] / contrib / bsdinstaller-1.1.6 / ports / sysutils / dfuife_cgi / Makefile
blob4de9ab2f29166461c5ba6c664f5285733994b9ce
1 # New ports collection makefile for: dfuife_cgi
2 # Date created: June 5, 2004
3 # Whom: Chris Pressey <cpressey@catseye.mine.nu>
5 PORTNAME= dfuife_cgi
6 PORTVERSION= 1.4
7 INTERNAL= YES
8 CATEGORIES= sysutils
9 DISTNAME= ${PORTNAME}-${PORTVERSION}
10 WRKSRC= work/cgi
12 LIB_DEPENDS= aura.3:${PORTSDIR}/devel/libaura \
13 dfui.4:${PORTSDIR}/sysutils/libdfui
15 MAINTAINER= cpressey@catseye.mine.nu
16 COMMENT= DFUI CGI frontend
18 PLIST_FILES= www/dfuife.cgi \
19 www/dfly-pg.gif \
20 www/fred-bg.gif \
21 www/fred.png \
22 www/dfuife.css \
23 www/dfuife.js \
24 www/index.html
26 do-fetch:
27 @if [ ! -f ${_DISTDIR}${DISTNAME}${EXTRACT_SUFX} ]; then \
28 ${ECHO_MSG}; \
29 ${ECHO_MSG} "Distfile ${DISTNAME}${EXTRACT_SUFX} not found!"; \
30 ${ECHO_MSG}; \
31 ${ECHO_MSG} "This is an 'INTERNAL' port, meaning that the distfile is not retrieved"; \
32 ${ECHO_MSG} "from the Internet, but rather created from a local checkout of the"; \
33 ${ECHO_MSG} "BSD Installer CVS repository. Please see the shell scripts in the"; \
34 ${ECHO_MSG} "scripts/build directory of the repository for more information on how"; \
35 ${ECHO_MSG} "to create these distfiles."; \
36 false; \
39 do-install:
40 ${INSTALL_PROGRAM} ${WRKSRC}/dfuife.cgi ${PREFIX}/www
41 ${INSTALL_DATA} ${WRKSRC}/dfly-pg.gif ${PREFIX}/www
42 ${INSTALL_DATA} ${WRKSRC}/fred-bg.gif ${PREFIX}/www
43 ${INSTALL_DATA} ${WRKSRC}/fred.png ${PREFIX}/www
44 ${INSTALL_DATA} ${WRKSRC}/dfuife.css ${PREFIX}/www
45 ${INSTALL_DATA} ${WRKSRC}/dfuife.js ${PREFIX}/www
46 ${INSTALL_DATA} ${WRKSRC}/index.html ${PREFIX}/www
48 OSTYPE!=sysctl -n kern.ostype
50 .if ${OSTYPE} == "FreeBSD"
51 .include <bsd.port.mk>
52 .endif
54 .if ${OSTYPE} == "DragonFly"
55 .include <bsd.dfport.mk>
56 .endif