Reduce differences with root_skels in contrib.
[dragonfly.git] / contrib / bsdinstaller-1.1.6 / ports / sysutils / dfuibe_installer / Makefile
blobc6ad07c1785542c0bdb6464d9de625a2e0c45e53
1 # New ports collection makefile for: dfuibe_installer
2 # Date created: May 13, 2004
3 # Whom: Chris Pressey <cpressey@catseye.mine.nu>
5 PORTNAME= dfuibe_installer
6 PORTVERSION= 1.1.6
7 INTERNAL= YES
8 CATEGORIES= sysutils
9 DISTNAME= ${PORTNAME}-${PORTVERSION}
10 WRKSRC= work/installer
12 LIB_DEPENDS= aura.3:${PORTSDIR}/devel/libaura \
13 dfui.4:${PORTSDIR}/sysutils/libdfui \
14 installer.5:${PORTSDIR}/sysutils/libinstaller
15 .if defined(WITH_NLS)
16 LIB_DEPENDS:= ${LIB_DEPENDS} \
17 intl.6:${PORTSDIR}/devel/gettext
18 .endif
20 MAINTAINER= cpressey@catseye.mine.nu
21 COMMENT= DFUI BSD Installer backend
23 SHAREDIR= ${LOCALBASE}/share/dfuibe_installer
25 .if defined(WITH_NLS)
26 LOCALEDIR= ${LOCALBASE}/share/locale
27 LANGUAGES= ru
28 .endif
30 PLIST_FILES= sbin/dfuibe_installer \
31 share/dfuibe_installer/cmdnames.conf
33 .if defined(WITH_NLS)
34 PLIST_FILES+= share/locale/ru/LC_MESSAGES/dfuibe_installer.mo
35 .endif
37 do-fetch:
38 @if [ ! -f ${_DISTDIR}${DISTNAME}${EXTRACT_SUFX} ]; then \
39 ${ECHO_MSG}; \
40 ${ECHO_MSG} "Distfile ${DISTNAME}${EXTRACT_SUFX} not found!"; \
41 ${ECHO_MSG}; \
42 ${ECHO_MSG} "This is an 'INTERNAL' port, meaning that the distfile is not retrieved"; \
43 ${ECHO_MSG} "from the Internet, but rather created from a local checkout of the"; \
44 ${ECHO_MSG} "BSD Installer CVS repository. Please see the shell scripts in the"; \
45 ${ECHO_MSG} "scripts/build directory of the repository for more information on how"; \
46 ${ECHO_MSG} "to create these distfiles."; \
47 false; \
50 do-install:
51 ${INSTALL_DATA} -s -o root -g wheel -m 555 ${WRKSRC}/dfuibe_installer ${LOCALBASE}/sbin
52 ${MKDIR} -p ${SHAREDIR}
53 ${INSTALL_DATA} -o root -g wheel -m 555 ${WRKSRC}/conf/cmdnames.conf ${SHAREDIR}
54 for _language in ${LANGUAGES}; do \
55 ${INSTALL_DATA} -o root -g wheel -m 444 ${WRKSRC}/po/$${_language}.mo \
56 ${LOCALEDIR}/$${_language}/LC_MESSAGES/${PORTNAME}.mo; \
57 done
59 OSTYPE!=sysctl -n kern.ostype
61 .if ${OSTYPE} == "FreeBSD"
62 .include <bsd.port.mk>
63 .endif
65 .if ${OSTYPE} == "DragonFly"
66 .include <bsd.dfport.mk>
67 .endif