Reduce differences with root_skels in contrib.
[dragonfly.git] / contrib / bsdinstaller-1.1.6 / ports / devel / lua50-posix / Makefile
blobade36091d807285d8f31d26c34b75b6b6bb41170
1 # New ports collection makefile for: lua50-posix
2 # Date created: 10 Feb 2005
3 # Whom: Chris Pressey
5 PORTNAME= lua50-posix
6 PORTVERSION= 2005.0327
7 CATEGORIES= devel
8 DISTNAME= lposix
9 WRKSRC= work/posix
10 MASTER_SITES= http://www.tecgraf.puc-rio.br/~lhf/ftp/lua/
12 LIB_DEPENDS= lua50.5:${PORTSDIR}/lang/lua50
13 BUILD_DEPENDS= ${LOCALBASE}/bin/lua50c51:${PORTSDIR}/devel/lua50-compat51
14 RUN_DEPENDS= ${LOCALBASE}/bin/lua50c51:${PORTSDIR}/devel/lua50-compat51
16 MAINTAINER= cpressey@catseye.mine.nu
17 COMMENT= POSIX bindings for Lua 5.0.x
19 PLIST_FILES= lib/lua/5.0/lposix.so \
20 share/lua/5.0/posix.lua
22 do-install:
23 ${INSTALL_DATA} ${WRKSRC}/lposix.so ${PREFIX}/lib/lua/5.0/
24 ${INSTALL_DATA} ${WRKSRC}/posix.lua ${PREFIX}/share/lua/5.0/
26 OSTYPE!=sysctl -n kern.ostype
28 .if ${OSTYPE} == "FreeBSD"
29 .include <bsd.port.mk>
30 .endif
32 .if ${OSTYPE} == "DragonFly"
33 .include <bsd.dfport.mk>
34 .endif